Skip to Content
author's profile photo Former Member
Former Member

SXMB_MONI - Message Status - Automatic Restart

Hello,

When a message in transferred, in transaction SXMB the message has an "AUTOMATIC RESTART" icon. Other messages stuck in the queue and are waiting for the message to restart.

Only after some time, the "AUTOMATIC RESTART" icon converts to "Red Flag" icon.

I would like to know if there is a way to stop the "Automatic restart" of the messages in transaction SXMB_MONI.

Please Advice,

Dimitry

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Apr 13, 2005 at 05:41 AM

    Hello Dimitry,

    Here is another way to delete the message from SXMB_MONI:

    1) On SXMB_MONI you click on the QUEUE_ID column in your problematic message, this enters you to the spesific queue where this message is in.

    2) Select the correct message in the queue and press delete.

    It's not a way to cancel the auto restart but it helps in some situations.

    Best reguards,

    Elad Saar.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 12, 2005 at 02:47 PM

    Hi,

    as far as I know, it is not possible from SXMB_MONI to prevent the restart of the queue. Maybe somehow in the q-rfc scheduler...

    What is your usecase?

    Good luck

    Holger

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 12, 2005 at 08:47 PM

    Dimitry,

    I dont know if you can disable automatic restart, but you can try to delete messages from Integration Engine. There are various ways to do that.

    1. In ABAP-stack. Transaction SMQ2, try to delete all messages currently stored in queues or try to identify based on time the exact message that is restarting.

    2. In J2EE-stack. In RWB, go to Message Monitoring, select time frame when this message first occurred. After, there is a button cancel to cancel processing of each individual message.

    Hope this helps,

    Dmitriy Mindich

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 22, 2005 at 03:39 PM

    Naveen,

    I couldn't find any forum by search method suggested by you. Can you help?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.