Skip to Content
author's profile photo Former Member
Former Member

Connecting to R/3 46c

Hi all, I'm trying to set up a jco connection to my R/3 system in the Web Dynpro area of the J2ee engine. When I click the test button, I get an error.

com.sap.mw.jco.JCO$Exception: (102) RFC_ERROR_COMMUNICATION: Connect to message server host failed Connect_PM TYPE=B MSHOST=s105hham GROUP=PUBLIC R3NAME=PRD MSSERV=sapmsPRD PCS=1 ERROR service 'sapmsPRD' unknown TIME Mon Apr 11 13:28:58 2005 RELEASE 640 COMPONENT NI (network interface) VERSION 37 RC -3 MODULE ninti.c LINE 494 DETAIL NiPGetServByName2: service 'sapmsPRD' not found SYSTEM CALL getservbyname_r COUNTER 1

When I hit the "Ping" button, it says that it failed to ping.

I thought that I set up everything correctly in the SLD. Can anyone give me a hint to what I am missing?

Regards,

Rich Heilman

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Apr 11, 2005 at 08:24 PM

    ERROR service 'sapmsPRD' unknown

    Just add the proper entry

    sapmsPRD 36xx

    Where xx is your system number to your services file under the etc directory

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.