Skip to Content
0

Create multiple service line items for a service PO using bapi_po_create1

Dec 21, 2016 at 12:32 PM

455

avatar image
Former Member

Hi Experts,

Pls help me.

I am creating multiple service line items for a single line item(ebelp) using

bapi_po_create1.

I took reference of OSS note: 420332.

It worked and I could create two service line items, but from the 3rd service line item its not getting created.

When executing BAPI, only a single subpackage no is getting generated for first two service line items and thus only two values are getting uploaded.

I am using flat file to enter multiple service line items.

Also only once account assignment is assigned to these two service line items while each service line item has different g/l account and WBS element.

Awaiting for your kind help.

Thanks and Regards,

Suchitra.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Nic Teunckens Dec 22, 2016 at 12:15 AM
0

Please check this SAP-KBA 2114353 "HowTo create Service PO with BAPI_PO_CREATE1" and apply the practises ...

If you still encounter problems, please post some of the ABAP-code concerning the BAPI-Structures before Calling the BAPI.

Maybe you can test your Custom-code by performing trx. "ANST" for your Custom Program => The Application will probably be able to point you to some missing SAP-KBA's ...

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Nic,
Thanks immensely for your kind, asap help and great guidance with OSS notes and tips to find the missing SAP-KBA's.
I could solve the issue of creating multiple service line items for a single line item.
I was mistakenly assigning package no to line no and incrementing it.
That was restricting creation of multiple service line items generation.
So i took a seperate variable for line no and initialized it.
Now i have to sort out the issue of g/l account and WBS element assignment.
I need to assign different g/l account and WBS element for different service line items.
But only the first row of these data from the flat file are getting assigned to the remaining
service line items. Will work on this and in case i find any obstacle will surely seek your kind guidance and help.
Thanks very much.
Kind Regards,
Suchitra.

0