Skip to Content
0
Former Member
Apr 08, 2005 at 12:47 PM

:-( Cannot start J2EE Engine

35 Views

5)

5.1) Under sapinst_instdir ... ONE_HOST ... the file sapinst_dev.log has the errors:

Error converting from service name=sapmsJ2E/protocol=tcp to port number. SAPRETURN=12

Error converting from port number=3601/protocol=tcp to service names. SAPRETURN=12

but port 3601 is free for use : the installation process itself created the entry in etc/services:

"sapmsJ2E 3601/tcp # SAP System Message Port".

There is also:

"E R R O R ******* (DbSapTable)

16:19:58 2005-04-10 sap-Error: setColumnsViaDb failed: [-708] Data receive failed [Software caused connection abort: recv failed].

E R R O R ******* (tools.DbTableOpenTools)

16:19:58 2005-04-10 ope-Error: Caused by: [-708] Data receive failed [Software caused connection abort: recv failed]. Stack trace: com.sap.dbtech.jdbc.exceptions.ConnectionException: [-708] Data receive failed [Software caused connection abort: recv failed].".

=====

4)

4.1) The error message "FSL-06002 Error 1060 (The specified service does not exist as an installed service.

) in execution of a 'OpenService' function, line (255), with parameter (SAPOsCol)."

appears in Phase "SAP System Installation" immediately after the display "Waiting for 30 seconds".

4.2) Exactly 30 seconds later the same message appears twice for SAPJ2E_01 and then, with the same timestamp, twice for the service SAPJ2E_00.

4.3) 56 seconds further on, it appears a second time for the service SAPOsCol.

4.4) These are the only error messages in that online log of the installation Phases.

4.5) The installation breaks down in the phase "Load Java Database Content"

4.6) The MaxDB is online.

4.7) The <host>1 instance has both processes green automatically for the download version, if I remember right I had to start it myself for the dvd version : it started to green.

4.8) C:\usr\sap\J2EE\JC00\work\ is empty: J2EE not started.

4.9) Under sapinst_instdir ... ONE_HOST ... the file jload.log has the error:

"SEVERE: com.sap.dictionary.database.dbs.JddException: CREATE TABLE BC_COMPVERS failed

at com.sap.inst.jload.db.DBTable.create(DBTable.java:106)

at com.sap.inst.jload.Jload.dbImport(Jload.java:276)

at com.sap.inst.jload.Jload.executeJob(Jload.java:395)

at com.sap.inst.jload.Jload.main(Jload.java:551)"

=======================

3)

3.1) After having run the install process using the SAPPress DVD I no longer get past Phase "Load Java Database Content" when thereafter installing, after uninstall, the downloaded Sneak Version.

3.2) In Phase "SAP System Installation" I get errors as described under search term "SAPOsCol" in the WAS General forum, independently of whether I use the SAPPress DVD or the download.

3.3) The SAPPress DVD installation blocks in Phase "Load Java Database Content" at "Java Hotspot(TM) Client VM (build 1.4.2_06-b03, mixed mode)" as does the download installation.

3.4) In both cases the MaxDB is running and ONLINE as I see in SAPMMC.

3.5) In both cases I have instance 1 with both processes running green as I can see in SAPMMC.

3.6 The last thing the install process does, as it says in its log, is to write the following to ... sapinst_instdir ... /jload.java.log:

"java version "1.4.2_06"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_06-b03)

Java HotSpot(TM) Client VM (build 1.4.2_06-b03, mixed mode)"

==============================

2) There do seem to be difficulties with this installation and I agree fully with the comments of David Pantich. I have been thru some OSS and some SDN but nothing helps. Also the inst guides.

I tried the DVD from SAPPress but it got irrevocably stuck early on, whereby the sneak at least got to the penultimate step.

I read from David Pantich in the Forum: Web AS General

that he used the following DVDs to finally succeed:

Installation Master DVD-#51030843

SAP Web AS Java-DVD-#51030724

Can anyone tell me how I might get these?

Thank you in advance.

Kind regards

David Lawn

================================================

1) Hi I have exactly the same error message as reported in an earlier Topic which is marked as Closed.

I need to reopen the topic since the 'solution' does not work for me.

In the penultimate WAS installation step, 'Start SAP J2EE Engine', I have:

"The log file startJ2E.log states the following:

running C:\usr\sap\J2E\JC00\exe/sapstart.exe name=J2E nr=00 SAPDIAHOST=<host name> -wait

Service restarted successfully.

SAPSTART finished successfully on gefdnb807_J2E_00, but at least one process doesn't run correctly:

C:\usr\sap\J2E\JC00\exe/sapstart.exe=>sapparam(1c): No Profile used."

I have SDK and JRE at 1.4.2_06.

I am on a PC with XP Family SP1 and 2 Go.

Is there any suggestion available?

Thanks in advance!

Kind regards

David Lawn

Message was edited by: David Lawn

Message was edited by: David Lawn

Message was edited by: David Lawn

Message was edited by: David Lawn