Skip to Content
0

How to see the ESR objects in PI 7.4 single stack in SPROXY T-code

Dec 21, 2016 at 10:52 AM

732

avatar image

Hi All,

Kindly suggest how to see the ESR objects in SPROXY T-code in PI 7.4. Recently my ECC system has upgraded. From when i got this issue.

The connections are working fine but am unable see the objects.

I have seen the ESR namespaces under NAMESPACEs, but newly developed objects are not shown in that.

I have checked under SOURCE- ESR but its getting error.

"An error has occurred during communication with ESR"

capture.png

Please find the attached screen shot....capture2.png

Kindly suggest on this....

capture.png (45.9 kB)
capture2.png (54.7 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Amit Bhagwat Dec 21, 2016 at 11:31 AM
0

Hi,

Please check entries in SXMB_ADM>Integration Engine Configuration>Configuration

Check the value for category RUNTIME parameter IS_URL which should point to your PI server.

The value should be like dest://<RFC DESTINATION>

RFC destination type G ( In case of single stack)

the destination can be changed in SXMB_ADM and SM59 if require

Thanks,

Amit

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Pls suggest one thing i have triggered the data from sender system, it is successfully coming to ECC. Is it happen when the above error will come..

0

Hi,

Yes, for incoming, you would have configured the proxy(SOAP) channel in PI so data will flow as inbound messages in ECC.

Outbound from ECC may not work for the error described in original post since RFC connections are not set.

Thanks,

Amit

0
Raghuraman S Dec 21, 2016 at 11:20 AM
1

Hello Ramu,

Go to SM59 and check general connection,You should maintain one connection here to view the ESR objects.

Check the below link for more details

http://www.saptechnical.com/Tutorials/XI/Proxy/AAE.htm

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Raghu,

I have maintained SAP_PROXY_ESR in sm59 the connection working fine...

0

Ramu,

Check the username in the connection,we had the similar issue because of wrong username/password+authorisation issues.

0