Skip to Content
avatar image
Former Member

SD- incompletion config.(plant mandatory )

Gurus,

i added plant field in incompletion at item level, when ever i try to save document it show document is incomplete with warning , but i can able to save document forcefully ,

my requirement is

i want to make plant mandatory(like sold to party in header) for item without plant document should not be save or forcefully save.

to save document u must be enter plant in item.

regards,

mahesh fulse

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Nov 28, 2011 at 05:46 PM

    Try to use user exit USEREXIT_CHECK_VBAP in the program MV45AFZB, to check the plant field. If the plant is missing, then you can provide hard error to the user.

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 29, 2011 at 06:25 AM

    Dear Mahesh,

    Go to T.code VOV8,select your sale document type there in transaction flow tab you can see Incomplete.messages tick the

    check box,it will not allow to save a sale order when it is incomplete,until you complete the required data.

    Regards

    Ram

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 29, 2011 at 06:07 AM

    In sales order type there is option incomplete message check it, the sales document will not save not only plant but any of the field if not maintained inthe document.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 29, 2011 at 06:16 AM

    Hi Mahesh,

    -- Go To T.Code VUA2 & select your sales document type.Here assign your incompletion procedure & check mark the IC-Dialog & save it.

    --Raise sales order with incomplete information (plant).when you try to save the document the system throws an error message but it will not allow to save the document with incompletion data.

    Let me know if your problem is assigned

    Regards

    Pradeep

    Add comment
    10|10000 characters needed characters exceeded