Skip to Content
0
Former Member
Nov 25, 2011 at 11:51 AM

EhP1 installer error (RFC of "SUBST_START_REPORT_IN_BATCH" failed)

69 Views

Hi,

we are trying to upgrade our CRM 7.0 to the EhP1 and the EhP1 installer is blocked with the error:

Checks after phase MAIN_SHDRUN/ALTNTAB_FILL were negative!
Last error code set: RFC call to SUBST_START_REPORT_IN_BATCH failed with key RFC_ERROR_SYSTEM_FAILURE (SYSTEM_FAILURE): connection closed without message (CM_NO_DATA_RECEIVED)

Log files report the following errors:

(altntfi.sav)
#--------------------------------------------------------------
#---- MASKING file ALTNTFI.LOG from G:\usr\sap\CR7\EHPI\abap\log
#---- TIME: 20111125115607  PHASE: ALTNTAB_FILL
#--------------------------------------------------------------
1 ETQ201 Entering upgrade-phase "ALTNTAB_FILL" ("20111125111509")
4 ETQ399 Set environment for standard connect:
2 ETQ367 Connect variables are set for standard instance access
4 ETQ399 System-nr = '02', GwService = 'sapgw02'
4 ETQ399 Environment variables:
4 ETQ399   dbs_ora_schema=SAPSR4
4 ETQ399   auth_shadow_upgrade=0
1 ETQ200 Executing actual phase 'MAIN_SHDRUN/ALTNTAB_FILL'.
1 ETQ399 Phase arguments:
2 ETQ399 Arg[0] = '30'
2 ETQ399 Arg[1] = 'ALTNTFI.ELG'
4 ETQ399 Set environment for shadow connect:
4 ETQ399 Set RFC variables for shadow connect:
4 ETQ399 System-nr = '07', GwService = 'sapgw07'
4 ETQ380 computing toolpath for request "TP_SHADOW_CONNECT"
4 ETQ381 request "TP_SHADOW_CONNECT" means "tp needs to connect to shadow system"
4 ETQ382 translates to group "R3UP_TOOL_GROUP_NEW"
4 ETQ383 translates to path "exe"
4 ETQ383 translates to path "exe"
4 ETQ399 Set tool parameters for shadow connect:
4 ETQ399   default TPPARAM: SHADOW.TPP
4 ETQ010 Date & Time: 20111125111509  
4 ETQ265 Starting report "RDDNT2MT" with variant "SAP_INIT" in batch
4 ETQ359 RFC Login to: System="CR7", Nr="07", GwHost="SYSKCRMDEV1", GwService="sapgw07"
4 ETQ232 RFC Login succeeded
4 ETQ233 Calling function module "SUBST_START_REPORT_IN_BATCH" by RFC
2EETQ360 RFC of "SUBST_START_REPORT_IN_BATCH" failed:
2EETQ361 code/exception  : SYSTEM_FAILURE
2EETQ362 key             : RFC_ERROR_SYSTEM_FAILURE
2EETQ364 message         : 
2EETQ399 connection closed without message (CM_NO_DATA_RECEIVED)
4 ETQ359 RFC Login to: System="CR7", Nr="07", GwHost="SYSKCRMDEV1", GwService="sapgw07"
4 ETQ232 RFC Login succeeded
2EETG894 Exception "SYSTEM_FAILURE" raised, write variant failed with error code -1
2EETG890 Exception "SYSTEM_FAILURE" raised, job scheduling failed with error code -1
2EETQ261 Start of batchjob "RDDNT2MT" failed
4 ETQ010 Date & Time: 20111125111548  

We have logged through GUI to the shadow instance but we can't test the function module SUBST_START_REPORT_IN_BATCH: the shadow instance continuously dumps (in SE37, ST22, ST11, SU01... with dumps LOAD_PROGRAM_CLASS_MISMATCH, GETWA_WRONG_LENGTH, LOAD_TYPE_VERSION_MISMATCH...). When I don't have a dump (i.e. I try to activate the function module in SE37 without opening it), the GUI closes with the error: "Work process restarted, session terminated " and in the logfile dev_disp shows me:

Fri Nov 25 11:15:30 2011
*** ERROR => DpHdlDeadWp: W5 (pid 17996) died (severity=0, status=0) [dpxxwp.c     1522]

Any help would be greatly appreciated.

Thanks,

laura.