Skip to Content
author's profile photo Former Member
Former Member

ZBUS1001 OLD_MATERIAL_CHANGED event does not trigger?

Hi All

I extended BUS1001 to ZBUS1001 and activated old_material_changed with SWU_EWCD - Change Documents wizard.

Then I defined this as a start event in my workflow and just to get started send a mail to wf initiator. If I run the workflow on it's own, it's fine, I get the notification. The event is actively linked. The binding is faultless. In SWEC the event change document exists with no limiting Field Restrictions. However, when I run SWELS, do a MM02 change and save, the SWEL does not indicate that this event was triggered at all? I'm not sure if BUS1001 actually has the old_material_changed event, because it does not exist in our system? Someone might have deleted it? Not sure where to continue looking for the cause of no triggering? Please advise.

Thanks,

Adrian

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Nov 24, 2011 at 05:53 PM

    Hello Adrian !

    BUS1001 is older version to BUS1001006.So, I suggest you to use BUS1001006.

    There is no event by name "old_material_changed" in BUS1001 or BUS1001006.One such event does not exist in these standard business objects.

    "Old_material_changed" should be a custom event.Configure this event in SWEC rather than in SWU_EWCD for "On change" for the change document "MATERIAL" and check whether workflow gets triggered.

    If it is not triggering, the only option is to find the suitable BAdI or user exit for the requirement.

    Regards,

    S.Suresh

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.