Skip to Content

Insert NULL date into ORACLE using ADBC

Hello everyone,

I'm using ADBC (like EXEC SQL OO) to insert values into an external database.

I need to insert null value into the fields type date.

I've already tried all the possibilities I can imagine...

TO_DATE('null'), only 'null', 'NULL' yyyymmdd, ddmmyyyy, 00.00.0000, 00000000, 00-00-0000, 00/00/0000, 00.00.0000 00:00:00, DECODE, space, ' '.

The only one that worked was ie 24-nov-2011.

But with this format, I can't insert NULL.

Do someone know how could I do?

Tks in advance.

Flavio.

PS: I'm using the GET REFERENCE functionallity.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Nov 24, 2011 at 01:29 PM

    Hi Flavio,

    I'm able to pass 'NULL' value to a Date field in ORACLE using Native SQL provided the date field defined in ORACLE is of type 'DEAULT NULL'.

    The value passed by the code is 'NULL' as is accepted in the destination system.

    Regards,

    Pranav.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.