Skip to Content
0
Former Member
Nov 24, 2011 at 10:48 AM

SDM agent is not registered with SDM server of Solution Manager server

95 Views

Hi,

We are in process of configuring EWA report for JAVA stack of SAP system along with ABAP stack. For ABAP stack the EWA report generation is straight forward and it is working fine. We are facing the problem while configuring EWA report for JAVA stack. Pls. find below the steps that we have followed and currently where we are stuck,

1) Installation of Willy introscope on Solman server.

2) Define JAVA component for each SAP system in SMSY

3) Installation of SDM Agent on all managed systems

4) Trying to attach SDM Agent to SDM server(solman) with the use of smdsetup.bat (managingconf & sldconf ).still we are getting error in smd agent log file as given below:

===============

Nov 24, 2011 6:16:09 PM [Thread[Connector,5,main]] Info [p4://xxxx.xxxx.int:8103] Checking server availability...

Nov 24, 2011 6:16:39 PM [Thread[Connector,5,main]] Error Failed to connect to SMD server - user: SMD_ADMIN

Nov 24, 2011 6:16:39 PM [Thread[Connector,5,main]] Warning Connecting to SMD server p4://xxx.xxx..int:8103 failed - error counter: 0 - com.sap.engine.services.jndi.persistent.exceptions.NamingException: Exception while trying to get InitialContext. [Root exception is com.sap.engine.interfaces.cross.DestinationException: cannot establish connection with any of the available instances

* Nested exceptions are:*

* com.sap.engine.services.rmi_p4.P4IOException: Cannot open connection on host: xx.xx.xx.xx and port: 8103*=================

5) The solman_setup t-code execution is successful in Solman server.

6) Trying to configure Technical system for JAVA system type through solman_setup : At this time we are getting another error as shown below:

========

The Managed System does not fulfil the Diagnostics prerequisites

Software with prerequisite are incorrect: Found SAP J2EE ENGINE 7.00 with sp level 0, minimum sp level required is 9: Please install or upgrade the required software component.========

I have gone through the SAP note: 1274287 : My solman system is already on the required patch level for LMservice and St 400 SP. Also, the managing systems Java patch level is more then sp06 which is minimum level required.

I need your help to know, why i am getting this SAP J2EE ENGINE 7.00 patch level error although my Java stack is up to date with the required patches.

Waiting for your reply friends.

Regards,