Skip to Content
0
Former Member
Nov 24, 2011 at 10:09 AM

CBS - Building - Error with JDK6

55 Views

Hi Experts.

This will probably the last time I am posting a threat, because I have almost finished my NWDI-Project.

I would like to deploy a simple "HelloWorld" JSP on SAP NetWeaver Portal 7.3.

But I do net want to deploy directly by the NWDS (by setting up a AS Server Java in the Preferences), but over the services of the NWDI (CBS ....).

First of all, I would like to give you an overview about my Systems and Landscape:

- NWDI 7.01 SP 7 => JDK 1.6.0_21

- NWDS 7.3 SP05 => JDK 1.6.0_? (not sure if correct installed, drop down for more info)

- Deploy/Runtime - System: SAP NetWeaver Portal 7.3 => JDK 1.6.0_? (correcty installed and it works)

I would like to give you a overview in this threat, what I did until now:

1. Installing JDK 1.6.0? on NWDI-System_

If I go in the NetWeaver Administrator (to the CBS-Service), I can se the following entry:

Name: JDK_HOME_PATHS

Wert: default=/usr/java14_64;JDK1.5_HOME=/usr/java5_64;JDK1.6_HOME=/sapmnt/XXX/global/sapjvm_6;

Name: BUILD_TOOL_JDK_HOME

Wert: -


(nothing, my SAP-BASIS sayed, that is right)

2. Generating a TRACK in the CMS - Landscape Configurator

- TRACK-Name: PORTAL73

- SCs: JSP7.3 => Dependencies to: ENGFACADE 7.30 and SAP_BUILDT 7.30

- Build Variants: Add -> Name: JDK6; New Build Option: Name: com.sap.jdk.home_path_key & Value: JDK1.6_HOME

JDK6 -> Assign Scs -> JSP7.3 -> Add

- Build Variants: Default -> Edit -> New Build Option: Name: com.sap.jdk.home_path_key & Value: JDK1.6_HOME

Default -> Assign Scs -> JSP7.3 -> Add

=> Checking-in the 2 SCs in the TRACK: ENGFACADE 7.30 and SAP_BUILDT 7.30

=> Checking-in the 2 SCs in the Development-System: ENGFACADE 7.30 and SAP_BUILDT 7.30

3. Working in the NWDS 7.30

- Import Development Configuration - File for Development-System

- Creating a simple "HelloWorld" JSP (with 2 DCs: Web Module & Enterprise Application)

- Local Build => SUCCESSFUL

=> Checking-In the Activity into DTR (successful)

=> Activating the Activity in the CBS

Now: After Activating in the CBS I got a "Request ID"

- I looked in the CBS -> Requests -> Request Status -> FAILED

So can you tell me please, what I did wrong?

Did I forget something?

Usually, after activating the activity in the CBS, I could call up my JSP in the Browser, by the following ULR, IS IT RIGHT:

http://<host>:<port>/contextRoot/portal.jsp

Thank you very much helping.

Best regards.