Skip to Content
author's profile photo Former Member
Former Member

No data shown on found posts from SAP table KNA1 - CR2011, ERP6.0 ehp4

I have a report connecting to SAP table KNA1 via SAP connector for tables.

When running the report it counts all posts but all fields are empty.

I discovered that the field specification sais the field length is 0 on all fields, but when running the report against another SAP system it has the correct field legths and the report works.

Anyone know what to do to set the correct field lengths for the connection?

Btw, OS is Windows 7 on the machine where Crystal Reports 2011 is running.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 29, 2011 at 05:11 PM

    Dear Mikael,

    Could you specify which patchlevel of the SAP Crystal Reports 2011 you are using? (SP/Patch)

    Also please make sure to have the appropriate Transports applied to the SAP Backend System.

    Please note that the minimum supported SAP Patchlevels for SAP Crystal Reports 2011 are:

    • SAP R/3 4.6c, BASIS level 41, ABA level 41

    • SAP R/3 4.7, BASIS level 41, ABA level 41

    Thanks!

    Thomas

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 15, 2011 at 11:52 AM

    Thank you for your information.

    We found out that the BO server is in version 3.1 and the client in version 4.0. When we installed the correct client for the BO server it worked just fine...

    /Mikael

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.