Skip to Content
0
Former Member
Nov 23, 2011 at 06:02 AM

RE:queue issue

29 Views

Hi all

i have an issue recently

They are Some standard demos that have worked in DED/DEA for years. Iu2019m not sure what could have changed to affect this

every message is struck in the queue .

A restart may not fix the issue, it looks like the XI cache cannot be refreshed. If you drill into the errors in the queue (transaction SMQ2), all of the issues point to the cache refresh issue.

If you try to run a cache refresh (transaction SXI_CACHE), you get the following message:

Problem during cache refresh.

Problem while updating a receiver agreement with object ID 79F6783DF67A3340BCD2DB8A0811B101. :Destination 4041CDC2F23A3B858D1D941B1124CCA7; HTTP error: Could not generate information for HTTP destination from specified SOAP data

When i used txn smq2. Drilling through some of these, I found the following in Msg ID .......

- http://sap.com/xi/XI/Message/30" xmlns:SOAP=" http://schemas.xmlsoap.org/soap/envelope/">

<SAP:Category>XIServer</SAP:Category>

<SAP:Code area="XICACHE">UPDATE</SAP:Code>

:

:

<SAP:AdditionalText>No RFC authorization for user XIAPPLUSER.</SAP:AdditionalText>

<SAP:Stack>Error while refreshing the XI runtime cache</SAP:Stack>

Are some more auth needed for the RFC connection user?

now the issue is solved but

1. What could have caused this issue ?

2. Is the issue permanently fixed ?

waiting for your valuable feedback

regards

sravan