Skip to Content
avatar image
Former Member

Can't backup Oracle DB on Windows 2008 R2 via DB13

Hi All,

I'm having an issue that is driving me nuts.

First off, I'm using CA arcserve version 16. I checked the read me and i fall into the supported versions.

Windows Server 2008 R2 Service Pack 1 x64 with BR*TOOLS 7.2 for Oracle 11gr2

Windows Server 2008 R2 x64 with BR*TOOLS 7.2 for Oracle 11gr2

I have no issues at all with Windows 2003/2008 server, just 2008R2.

I have 10 2008R2 servers and all of them do not work.

I can use DB13 to run a local backup to disk. No Problem.

I can use Brtools to run a backup to disk. No Problem.

I can use Brtools to run a backup with a Util_file to my tape unit and CA Arcserve manager no issues.

I cannot use DB13 to backup with a Util_file.

The very same server using the uttil_file with brtools, will not work with db13.

Error is,

BR0280I BRBACKUP time stamp: 2011-11-18 14.01.43

BR0279E Return code from 'D:\usr\sap\S90\SYS\exe\uc\NTAMD64\backint.exe -u S90 -f backup -i D:\oracle\S90\sapbackup\.behgdxaa.lst -t file -p D:\oracle\S90\11202\database\initS90.utl -c': 22

BR0232E 0 of 21 files saved by backup utility

BR0280I BRBACKUP time stamp: 2011-11-18 14.01.43

BR0231E Backup utility call failed

ALl my 2003 and 2008's work fine.

ANyone have SAP running on 2008R2 and can use a util_file via DB13?

Edited by: Joshua Lacroix on Nov 18, 2011 8:45 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • avatar image
    Former Member
    Nov 18, 2011 at 10:16 PM

    Hi,

    Could you check the SAP service user on Windows Services? It should be SAPService<SID>.

    Additionally, check SAPService<SID> is member of the ORA_<SID>_DBA and ORA_<SID>_OPER groups. You may try to add SAPService<SID> user to "Administrators" group to be sure the problem is not cause by security problem.

    Best regards,

    Orkun Gedik

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      So i've been debugging..From DB13, it does pass it to windows and then windows tries to execute it.looks clean...I cant fingure this out...

      Log Name: Application

      Source: Oracle.s90

      Date: 11/21/2011 4:19:02 PM

      Event ID: 34

      Task Category: None

      Level: Information

      Keywords: Classic

      User: N/A

      Computer: SAPSRV60.saps.local

      Description:

      Audit trail: LENGTH: '180' ACTION :[7] 'CONNECT' DATABASE USER:[1] '/' PRIVILEGE :[4] 'NONE' CLIENT USER:[19] 'NT AUTHORITY\SYSTEM' CLIENT TERMINAL:[8] 'SAPSRV60' STATUS:[4] '1031' DBID:[10] '3556861972' .

      Event Xml:

      http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

      <Provider Name="Oracle.s90" />

      <EventID Qualifiers="16386">34</EventID>

      <Level>4</Level>

      <Task>0</Task>

      <Keywords>0x80000000000000</Keywords>

      <TimeCreated SystemTime="2011-11-21T21:19:02.000000000Z" />

      <EventRecordID>129844</EventRecordID>

      <Channel>Application</Channel>

      SAPSRV60.saps.local

      <Security />

      </System>

      <EventData>

      <Data>LENGTH: '180' ACTION :[7] 'CONNECT' DATABASE USER:[1] '/' PRIVILEGE :[4] 'NONE' CLIENT USER:[19] 'NT AUTHORITY\SYSTEM' CLIENT TERMINAL:[8] 'SAPSRV60' STATUS:[4] '1031' DBID:[10] '3556861972' </Data>

      </EventData>

      </Event>

  • avatar image
    Former Member
    Dec 01, 2011 at 02:46 PM

    Hello!

    I have the same problem on Win2008 serv oracle10:

    BR0279E Return code from 'backint -u ZAZ -f backup -i D:\oracle\product\brlogs\saparch\.aehiovkg.lst -t file -p D:\oracle\product\10.2.0\database\initZAZ_00.utl -c': 2

    BR0232E 0 of 2 files saved by backup utility

    BR0280I BRARCHIVE time stamp: 2011-12-01 16.19.30

    BR0231E Backup utility call failed

    BR0016I 0 offline redolog files processed, total size 0.000 MB

    All worked ok, but after implement windows update, backup stopped working.

    I have no idea how to solve this problem.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 01, 2011 at 03:06 PM

    Check in the event log whether there is more information about a possible issue.

    Markus

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Yes i have and and check this. Windows gets the call from DB13, DB13 passes windows all the information, and windows passes it to oracle and it dies there.

      check the log of the DB13 call

      Log Name: Application

      Source: Oracle.he1

      Date: 12/1/2011 2:41:11 AM

      Event ID: 34

      Task Category: None

      Level: Information

      Keywords: Classic

      User: N/A

      Computer: SAPSRV69.saps.local

      Description:

      Audit trail: LENGTH: '176' ACTION :[7] 'CONNECT' DATABASE USER:[1] '/' PRIVILEGE :[6] 'SYSDBA' CLIENT USER:[18] 'SAPS\SAPServiceHE1' CLIENT TERMINAL:[8] 'SAPSRV69' STATUS:[1] '0' DBID:[9] '882590849' .

      Event Xml:

      http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

      <Provider Name="Oracle.he1" />

      <EventID Qualifiers="16386">34</EventID>

      <Level>4</Level>

      <Task>0</Task>

      <Keywords>0x80000000000000</Keywords>

      <TimeCreated SystemTime="2011-12-01T07:41:11.000Z" />

      <EventRecordID>695</EventRecordID>

      <Channel>Application</Channel>

      SAPSRV69.saps.local

      <Security />

      </System>

      <EventData>

      <Data>LENGTH: '176' ACTION :[7] 'CONNECT' DATABASE USER:[1] '/' PRIVILEGE :[6] 'SYSDBA' CLIENT USER:[18] 'SAPS\SAPServiceHE1' CLIENT TERMINAL:[8] 'SAPSRV69' STATUS:[1] '0' DBID:[9] '882590849' </Data>

      </EventData>

      </Event>

  • avatar image
    Former Member
    Dec 02, 2011 at 03:33 PM

    Joshua,

    on this system SAP BOBJ, not Netweaver and worked during 6 mounth without a problem.

    In the near future we are going to upgrade Oracle to 11G, but today we have a problem, which appeared after install windows update.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 09, 2011 at 08:17 AM

    Hi,

    Try installing the SAP Standalone gateway. In The MSCS cluster environment you need to have the Standalone gateway in place.

    Refer SAP Note 657999 - Installing a Standalone Gateway in an MSCS Environment

    Regards

    Mukunthan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Rajesh,

      Thanks i checked that out. But also keep in mind, i can run DB13 backups to DISK!!!

      So...anything to do with rights and priveliges should be fine right? I can also run BRtools to Tape....just not DB13 to Tape.

  • avatar image
    Former Member
    Dec 14, 2011 at 04:30 AM

    Hi,

    You need to install the Standalone gateway to take the MSCS cluster database backup. There is a note available for the same

    Regards

    D.Mukunthan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      D.Mukunthan,

      I read the note but i'm not running a Microsoft Cluster Server. My servers are all standalone servers with windows 2008 r2. Runnins one SAP application.

      This is why i haven't tried the note because i read it and understood it to be related only to a cluster of servers.