Skip to Content
avatar image
Former Member

Help With TREX:There are no active http servers known to the nameserver

Hello all,

I've install the Sneak Preview but for some reason TREX is not working for me.

When I try to create a new index in the portal I get a message: Index could not be created: There are no active http servers known at the nameserver (Errorcode 7218).

I guess i'm missing something in the post-installation procedure.

I've already used the Visual Administrator to set the nameserver host/port and I already setup the new IIS "web application" for this TREX Instance (not sure this was needed but I did it anyway).

I just cant find where to tell the nameserver to use the http server.

Please help

/NL

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    May 03, 2005 at 01:26 AM

    Hello Nir,

    On the Trex server, please check the configuration file <TREX_DIR>/sapprofile.ini. There should be a parameter named 'TREX/NameServer/Port' which gives the correct port number for the name server. Use this port value for the Trex service parameter 'nameserver.address'

    The host and port should be filled in accordingly:

    tcpip://<host_name_of_trex_host>:<name_server_port>

    Verify that the url specified in <TREX_DIR>/topology.ini is accessible:

    <httpserver>

    <<port>>

    url=http://<trexhost>:<port>/ ...

    ...

    The Trex Web Service must be started and properly configured so that the TrexHttpServer.dll file is referenced with the correct path.

    Regards,

    Nathan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Thanks Nathan.

      Uninstall and re-install did eventually solved the problem. As you said I needed to check the "Install HTTP Server" in the installation wizard (pity the doc say no need change anything).

      Thanks for the help...

      /NL

  • avatar image
    Former Member
    Apr 19, 2005 at 09:30 PM

    Hi Nir,

    I am having the same problem, if you have a fix please help.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 05, 2005 at 02:20 PM

    Where is this option on the Sneak Preview installation? I haven't seen it. This installation is pretty much next, next and that's all. Perhaps i must install the official version?

    Thanks in advance.

    Homer Vargas

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 30, 2007 at 06:21 AM

    hi

    I am also getting the error

    "Index could not be created; creating index failed: There are no active http servers known at the nameserver. (Errorcode 7218)"

    Please help me on this.

    Add comment
    10|10000 characters needed characters exceeded