Skip to Content

BAPI_BUPA_FS_CREATE_FROM_DATA2 BP Number Ranges problem

Hi Experts,

We have the requirement to create an upload tool for our Master Data Team so that in future they can upload the Business Partners via Excel instead of entering them manually.

For this requirement we use BAPI_BUPA_FS_CREATE_FROM_DATA2. We devised a way to run the BAPI also in test modus, so that the user first can test if all data are correct.

We are faced with an important issue for this. When we create the Business Partners in test modus they are assigned already a BP range (8990 to 8999). Now the problem is that the BAPI apparently stores the BP ranges it creates in test modus (Note: they are not actually created, so they cannot be displayed via BP, but it apparently assigns already a BP number to it).

When actually running the program in production run the program creates a new BP number range (BP form 9000 to 9010 e.g.).

This will give number range gaps in the BP which is off course not acceptable.

Kr,

Stef

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Nov 17, 2011 at 04:11 PM

    Hi,

    The reason for this is, system is allocating the number from number range (Creating BP) and since you are not doing 'bapi_transaction_commit' at the end of the program these are not updated in the tables(rolled back) and yet system consumes the number range.

    Hope this helps!

    Reetesh

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 17, 2011 at 05:53 PM

    Try this: go to transaction SNRO and edit number range BU_PARTNER. The standard value for field 'Number of numbers in buffer" is 10. Change it to 1.

    If the BAPI test is not successful remember to perform a ROLLBACK WORK so that the system does not update table NRIV

    If still does not work then try to deactivate buffering (menu Edit->Setup Buffering->No buffering) because that is the way that FI number ranges work.

    Edited by: Arseni Gallardo on Nov 17, 2011 7:09 PM

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      I don't think for a testing scenario it is recommended to stop buffering of number ranges; if you create BP partner through T-code this will not happen.

      If you are testing thru SE37 use test sequence, where you enter your BAPI and then call commit bapi in sequence.

      Reetesh

  • author's profile photo Former Member
    Former Member
    Posted on Nov 17, 2011 at 09:24 PM

    This doesn't seem right to me. There are a number of notes related to number ranges when simulating, so I think you should send this to OSS.

    Rob

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 18, 2011 at 08:25 AM

    Hi Stef

    Just a sggestion, why dont you copy the standard BAPI in a ZBAPI of your own, and probably put a flag distinguishing the test run from the actual run, and call the commit work (BAPI_TRANSCTION_COMMIT) conditionally !

    Hope it helps

    Rgds

    Sameer

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.