Skip to Content

Connection ERP 6.0 --> PI 7.1 (SPROXY)

Hi all,

I'm having some trouble to connect ERP --> PI 7.1 through SPROXY

All configurations about SLD was done, but the services doesn't appear in the SPROXY.

There is no message showing any problem in the SLDCHECK:

16.11.2011 Exchange Infrastructure: teste da conexu201Eo LCR 1

-


Properties of RFC destination SAPSLDAPI

RFC host:

%%RFCSERVER%%

program id: SAPSLDAPI_PID

gateway host:

10.0.2.73

gateway service: sapgw01

Testing the RFC connection to the SLD java client...

RFC ping was successful

SLD server access settings:

host name: xxx0202

port number: 50100

user : PIAFUSER

Use transaction SLDAPICUST if you wish to maintain the SLD server access data

Launching the SLD GUI in a separate browser window...

=> Verify in the browser GUI that the SLD is in a healthy running state!

Calling function LCR_LIST_BUSINESS_SYSTEMS

Retrieving data from the SLD server...

Function call terminated sucessfully

List of business systems maintained in the SLD:

INTEGRATION_SERVER_PID

ECD

Calling function LCR_GET_OWN_BUSINESS_SYSTEM

Retrieving data from the SLD server...

Function call terminated sucessfully

Properties of own business system associated to system ECD client 100

id = ECD

role = LOC

Calling function LCR_GET_BS_DETAILS

Retrieving data from the SLD server...

Function call terminated sucessfully

Details of own business system ECD

caption = ECD

product =

IS-URL = http://xxx0202:50100/sap/xi/engine?type=entry

-


Summary: Connection to SLD works correctly

-


Now checking access to the XI Profile

Properties of RFC destination LCRSAPRFC

RFC host:

%%RFCSERVER%%

program id: LCRSAPRFC_PID

gateway host:

10.0.2.73

gateway service: sapgw01

Testing the RFC connection to the SLD java client...

RFC ping was successful

Calling function EXCHANGE_PROFILE_GET_PARAMETER

Retrieving data from the XI Profile...

Function call terminated sucessfully

Retrieved value of

section = Connections

parameter = com.sap.aii.ib.server.connect.webas.r3.ashost

-> value =

-


Summary: Connection to the XI Profile works correctly

-


Somebody knows what I have to do?

tks

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Nov 16, 2011 at 02:14 PM

    Hi,

    Have you done the configuration in sxmb_adm---> Integration Engine Configuration (R3 system).

    and also perform SXI_CACHE refresh then try again.

    please refere below links,

    sldcheck-failed,-connection-to-sld-does-not-work

    http://help.sap.com/saphelp_nw04/helpdata/en/78/20244134a56532e10000000a1550b0/content.htm

    regards,

    ganesh.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 16, 2011 at 02:11 PM

    did you create the service under the namespace http://sap.com?

    this status belong SLDCHECK in PI server? if yes, so execute the SLDCHECK in ERP. if youface any error contact your basis team to configure properly the connection between ERP and PI and the sproxy transaction code.

    Rgds

    RP

    Edited by: Rodrigo Alejandro Pertierra on Nov 16, 2011 12:16 PM

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 16, 2011 at 02:13 PM

    Hi,

    What is the error that you are getting when you execute the tcode SPROXY.....Please check your proxy preconfiguration steps.

    http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/50d69314-1be0-2b10-11ab-8045021f0c3a

    Regards,

    Priyanka

    Add comment
    10|10000 characters needed characters exceeded