Skip to Content
author's profile photo Former Member
Former Member

transaction data loading error

I have one info-cube: C1, characterstic: Time(0calday), material number(IO_MAT), company code (0comp_code)

key figure: price of material (IO_PRC)

I create one datasource for transaction data

Material Comp code Price

110001 7770 23

when I create transformation, it says error 1::

Rule 2 (target field: IO_PRC): Field PRICE must be assigned to an InfoObject

Message no. RSTRAN526

Diagnosis

No InfoObject is assigned to field PRICE. This is mandatory if you want to use the corresponding rule type.

System Response

The rule is invalid.

Procedure

Assign an InfoObject to the field

error 2:

Key rule 3 (target field: 0CALDAY): Initial update set

Message no. RSTRAN508

do I need another column in my upload file for date? should I put "16/11/2011" or "11.16.2011" for example?

if I don't provide date, is it ok to run DTP? thanks

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 16, 2011 at 08:55 AM

    Hi,

    In Transformation you have to assign your keyfigure(Price ) to a field from datasource. So it is required to a add a new field for Price in Datasource. If you are not mapping any fields to Price how will it get data?

    Even for date field you have to map it to a date field of source.

    DAte format should be YYYYMMDD. In case if you want to use the formats you have specified use external format option in the DS.

    Hope this helps,

    Aparna Duvvuri

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 16, 2011 at 11:28 AM

    Hi,

    Your flat file structure must be similar to the format as designed in the flat file data source. Also in the transformation you need to map source fields to the target fields otherwise no value will be passed to the infoprovider. If you do not want to map these fields then you should define a rule such that values for those columns get populated through some routine or constant but in that case in your flat file the column for these field must be blank that is SPACE in between commas.

    Navesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 18, 2011 at 08:51 AM

    In the transformaton check the rule details of the target price field .In the rule details check whether for currency the rule is no conversion or not.If it is not please do it.It will help

    Edited by: shyam agarwal on Nov 18, 2011 9:51 AM

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 18, 2011 at 08:52 AM

    Hi,

    Check ubit field mapping in Price.

    Delete the rule completely and recreate it once again.

    Refer to following thread

    Thanks and regards

    Kiran

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 18, 2011 at 10:27 AM

    hi santosh,

    1) Check whether you have placed the correct info-object, in the cube, which you have created. some times we might create the similar object and might replace them instead one of the other.

    2) Click on the rule details and give the IO assignment manually. Activate and check...

    Thanks,

    Malathi

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Prashanth Konduru

      No, I already know that two records are loaded through monitor, what I want to know the content of these two new records, how to achieve is? throgh which t-code? through which table i can see the change if my cube name is Z1?

      I'm using BI7 and I load data from flat file, my DTP setting is "DO NOT Extract from PSA but access data source", any solution?

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.