Skip to Content
avatar image
Former Member

EarlyWatch report

Hi,

I have my earlywatch report setup to run weekly. The report has red flag and when I click on it brings up a screen which asks to check few things like:

Go to the Service Data Control Center (transaction SDCCN) in the managed system and check why the data has not been sent.

Typical sources of errors are:

The RFC connection for the SAP Solution Manager system is not working.

The 'Task Processor' background job, which collects the session data, has been changed.

Problems arose while data was being collected (see the detail log for the task that collects the session data).

A periodic 'SDCC Maintenance Package' task has not been scheduled to check whether your SAP Solution Manager system requests session data.

Session number: 0010000002453

The RFC is working fine when I run a test. Task processor job has been running, however when I look at the "Task log" in both solution manager and my Managed system, it shows task failed. "Task not found. Deleted or status not "To do", ending task processor".

I also looked in the joblog for this job "/BDL/TASK_PROCESSPR which shows same error.

What am I missing here? when I run the report on demand, it runs fine and returns data. Does the "Maintenance package need to run on both solman and managed system? I have it running on solman only. Please let me know if you have experienced this? thanks!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Nov 11, 2011 at 06:29 PM

    Hello,

    can you please review my wiki article on this error here:

    http://wiki.sdn.sap.com/wiki/x/SAObDQ

    This covers off most the causes, so please go through it carefully.

    Keep in mind this may be due to a problem with the service session on Solution Manager too, so you need to see if you can open the session in transaction DSA....you can get the session number by clicking on the link for the EWAwith the red flag.

    Open the session means opening it so you can see the details in the session.

    I am just mentioning this one specifically as it tends to be the one possibility that is always overlooked.

    IYou should be able to find where the process has failed by following the Wiki article.

    Regards,

    Paul

    Add comment
    10|10000 characters needed characters exceeded

    • Hello,

      If you can rung the refresh session task on the managed system and it send the data to Solution Manager ( red flag changes to 2 flasks, sm:EXEC services runs EWA is processed). This means the infrstucture is sound and that the Maintenance Package task is encountering an error, as it kicks of the Refresh Defintions task and the Refresh Session Task, much like the refresh session task will kick of an EWA task ( if there is an unprocessed session on Solman for it.

      So you want to view the log fo rthe Maintenace Package Task (not the task processor log).

      I can tell you 100% if you can generate the EWA by just manually running a Refresh Session Task (not Solution), and the only

      tasks you have scheduled in SDCCN are the Service Preparation task and the Maintenance Package task, then with certainty the Maintenance PAckage task is failing. You need to review its log and determine why to address it.

      What might help is to know it is going to try and refresh service defintions. IS the RFC SDCC_OSS functioning? If not the Maintenance package task will not kick off the dependant tasks......and this may not be noticable as such in the log.

      Also inspect what is defined in SDCCN >Settingds > Task Specifc > RFC Destinations. The reason the refresh session task will try and refresh from all RFC destinatiosn listed here, and again if one is defined and it fails, the EWA can remain red flagged.

      When you run the task manually, you specify the one RFC and that is a difference. But the automation of the EWA is dependant upon the the Maintenance package encountering no errors as this break the automation.

      I thinkl you have proven this is the case. Now comes the task of determining why. I think I have provied a few hints that may help

      One thing I see people do, that is not a best practice, is when they have a similar issue, rather than fix it, the make the refresh session task a periodic task. The reason this is not a good idea is if there are new service defintions, they won't be loaded to the managed system and the resulting EWA may be erroneous becuase of it. So I advise finding the problem to resolve.

      Regards,

      Paul

  • Nov 23, 2012 at 09:30 AM

    Hi Sadat,


    Fix the problem by deactivating and reactivating the SDCCN task processor:

    SDCCN->GoTo->Settings->Task Processor->Change Settings->Deactivate-> Set Defaults- Activate


    possible reason : some refresh sessions tasks could not be performed because there is no RFC connection related to an old solman in SDCCN. If these tasks are old and no longer needed, delete them.

    regards, jean

    Add comment
    10|10000 characters needed characters exceeded