Skip to Content
0

Error during the System Copy (Heterogeneous)

Dec 20, 2016 at 10:59 PM

279

avatar image

Hello,

OS: Aix 6.1
DB: DB6 (DB2 LUW) 9.7 (9.07.0005)

I´m performing a heterogeneous system copy. For this I´m using the Sofware Provisioning Manager SP18 (SWPM) and I´m open it with the <sid>adm.

But unfortunatelly I´m with the following error during the SWPM and I don´t know how to solve it. Can you check the last lines of the following sapinst.log file, please?

...

INFO 2016-12-20 17:09:46.620 (quaadm/sapsys)
Execute step CheckDB2Software of component |NW_Export|ind|ind|ind|ind|0|0|NW_GetSidFromProfile s|ind|ind|ind|ind|getSid|0|NW_getDBInfo|ind|ind|ind |ind|dbinfo|0|NW_DB6_Initialize_Db_Software_Info|i nd|ind|ind|ind|db6initializeparameters|0

WARNING 2016-12-20 17:09:47.401 (quaadm/sapsys) id=modlib.jslib.getEnvFailedNotRoot
Cannot read environment of user db2qua: permission denied.

INFO 2016-12-20 17:09:47.527 (quaadm/sapsys)
Creating file /portugal/sapinstdir/sapinst_instdir/NW731/DB6/COPY /EXP/AS-ABAP/EXP/db2level.log.

INFO 2016-12-20 17:09:47.657 (quaadm/sapsys)
Output of /db2/QUA/sqllib/bin/db2level is written to the logfile db2level.log.

WARNING 2016-12-20 17:09:47.859 (quaadm/sapsys) id=modlib.jslib.childAppReturn
Execution of the command "/db2/QUA/sqllib/bin/db2level" finished with return code 100. Output:

ERROR 2016-12-20 17:09:47.861 (quaadm/sapsys) id=dbmoddb6.generic errno=MDB-01999
Executable </db2/QUA/sqllib/bin/db2level> has Returncode <100>.

ERROR 2016-12-20 17:09:47.862 (quaadm/sapsys) id=modlib.jslib.caughtException errno=MUT-03025
Caught ESAPinstException in module call: Executable </db2/QUA/sqllib/bin/db2level> has Returncode <100>..


Can you help me please? Any tips? How can I solve this error?

I believe that everything would be solved if I run this with root user but unfortunatelly I can start the X window (xclock) with the root user therefore I can't open the SWPM with the root user! When I try this it show me always the following message:

/home/root# xclock
Xlib: connection to "localhost:12.0" refused by server
Xlib: MobaXterm X11 proxy: Unsupported authorisation protocol

Error: Can't open display: localhost:12.0

Can you help me please?... this is urgent!

Best regards,

JDimas

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Balamurugan Sambandam Jul 14, 2017 at 04:45 PM
0

Hi,


Did you solve the issue. I am also getting the same error.Can you please share the solution if you have?

Thanks in advance.

Regards,

Bala.

Share
10 |10000 characters needed characters left characters exceeded
Manjunath Hanmantgad Jul 16, 2017 at 05:41 PM
0

Hi Joao,

The most likely reason you are getting this error is that the existing instance was not installed by root. You can check by, logged in as the instance owner, running: #db2greg -dump Look for the lines starting with a capital "S". You can find out which user installed the system.If you have a non root uid in that column (check who it is in /etc/passwd), then your install is a non-root install and running the process as root will be disallowed.

Regards,
Manjunath Hanmantgad

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Just to add on:

In case the issue is still persisting attach the sapinst_dev.log here to check.

Regards,
Manjunath Hanmantgad

0