Skip to Content
0

MTB and FCC with ASMA in SAP SFTP Adapter

Dec 20, 2016 at 09:58 PM

57

avatar image

Hi All,

We recently switched from Advantco SFTP adapter to SAP SFTP Adapter.

In the Advantco Adapter we were able to pull fixed length files where the last field is mostly blank.We were using FCC and had ASMA enabled to retain the source filename as that was used by Dynamic Config in some UDF.

Now when we switched to SAP SFTP Adapter and configured with FCC and ASMA all files are pulled but they need all the fixed length parameters. The files which were having the last field as blank stopped working.

We are also trying to use MTB but even though it picks up the files with Source Name(ASMA still enabled) it adds a RecordSet to it thus the mapping fails.

We are not in a position to make too many changes in mapping. How do we fix either the FCC to pull the files with last field as blank or using MTB and remove the extra Record Set it is generating

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Evgeniy Kolmakov Dec 21, 2016 at 03:44 AM
1

Hi Shaibayan!

You can use very simple XSLT (or java mapping) before your message mapping to remove "RecordSet" element from your structure.

Regards, Evgeniy.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

The idea is not to change the mapping and fix this at the channel level.

0

You don't change your current mapping, you just add additional one before your main mapping.

Other option is to use MessageTransformBean with XSL transformation in communication channel to remove Recordset element.

Regards, Evgeniy.

1
Manoj K Dec 21, 2016 at 05:05 AM
0

Shabiyan,

Try parameter

xml.missingLastFields = add in FCC.

Personally have never tried this with FCC , this works fine with MTB.

Br,

Manoj

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Manoj,

With MTB I do not need to use the missingLastFields as it picks up the file without issue but the Source structure is altered which results in mapping failure.

I tried this parameter with FCC and it does not work.

We are using SAP PI 7.4 SP12 and a very latest SAP SFTP Adapter.

Thanks,

Shaibayan

0