Skip to Content

sapstartsrv not started (HANA installation)

Can you please tell me what is the steps to a full working HANA system , when I have installed the following in the order

1. sap_host_agent ( rpm install)

2. hdb_server (hdbsetup)

3. hdb_client (hdbinst -a studio)

4. lm_struc (hdbinst -a lm )

I have not done the SUM installation yet , as it for updating and is not really required right away for full functioning of HANA system . As such hdbdaemon, hdbnameserver, hdbpreprocessor, hdbindexserver, hdbstatisticserver are all green and running.

Please note that I did not find /sapmnt .. that I seems that it should have beenautomatically created during the hdb_server setup.

so is the manual creation and mounting needed now ?

I have created the HANA database and its running SID HAN , instance# 00

What is the next step , adding host (hbdaddhost) ?

and how do i it .. rather what are the command line parameters i need to input .

The installation guide is not very clear on it .

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

8 Answers

  • Best Answer
    Nov 10, 2011 at 04:33 AM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 26, 2013 at 03:14 PM

    This discussion gives a great deal of inforamtion. But, it is never mentioned how exactly a FQDN has to be in the hosts file.

    Is it something like:

    EIP ec2-xx-xx-xx.xxxxxx.compute.amazonaws.com

    or like :

    EIP ec2-xx-xx-xx ec2-xx-xx-xx.xxxxxx.compute.amazonaws.com

    Currently I have added the below FQDN to my hosts file in this form but do not work...

    EIP ec2-xx-xx-xx ec2-xx-xx-xx.xxxxxx.compute.amazonaws.com

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 10, 2011 at 08:58 AM

    Hello,

    to have working system all you need (the minimum) is to install only SAP HANA database - other parts are not critical for SAP HANA to run without issues... (of course there is reason to have them installed)

    Regarding the "missing" /sapmnt directory - it seems that in case of SAP HANA it does not need to be explicitly names as /sapmnt - see image on page 14 in Server installation guide:

    https://service.sap.com/~sapidb/011000358700000604572011

    Can you find on your server /hdbmnt filesystem/directory?

    If you are looking for log files please switch to <sid>adm user and go to trace directory:

    su - hanadm
    cd $SAP_RETRIEVAL_PATH/trace
    cat sapstartsrv.log

    Please paste here the log file.

    Note: If you want to try to resolve this really fast without trying to identify reason - it might be possible solution to stop SAP HANA and then to kill sapstartsrv process (just be sure that you really stopped all child processes). After next start of SAP HANA new startsapsrv process will be created.

    Tomas

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 21, 2012 at 01:19 PM

    Hi,

    In case of nothing above worked, you can update windows hosts file with IPs.

    Boris

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 24, 2012 at 05:33 PM

    Hi,

    I could add a new system in the HANA Studio without any error. Name of tables appear, but the problem is when I run the query it does not show any retrieved data. here is the snapshot of the error which is: "Error on refreshing system". I tried all of the solution here, but still it does not work. Does anyone have any Idea?

    Thank you

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 08, 2014 at 05:57 PM

    Hi Rajarshi,

    any clue how I can see if the host agent is running in my HANA server?

    and if not how can in install it?

    my Lifecycle manager is not getting connected from the HANA studio because of this.

    a quick reply would be really appreciated.

    Thanks,

    Nitin Jain

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 28, 2015 at 11:02 PM

    Hi Colleagues,

    When im performing HANA cluster installation we are getting error like:

    we are facing an issue when we are trying to add host in secondary as like below:

    mo-599bcd458:/mnt/shared/W15/global/hdb/install/bin # ./hdbaddhost


    SAP HANA Lifecycle Management - Database Addhost 1.00.095.00.1429086950
    ***********************************************************************



    Enter Local Host Name [mo-599bcd458]:
    Enter System Administrator (w15adm) Password:
    Add host failed
    Cannot verify password: sapstartsrv of host 'mo-88059af8e' is not running
    Cannot establish http connection to 'mo-88059af8e:50213' (Net::HTTP: connect: Connection timed out)


    At the same time, sapstart srv is running fine in prmary:

    mo-88059af8e:~ # lsof -i -n -P | grep 50213
    sapstarts 9831 w15adm 11u IPv4 113607 0t0 TCP *:50213 (LISTEN)


    Kindly let us know how can we establish the connectivity of sapstartsrv between primary and secondary.


    Regards,

    Raghu

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 21, 2015 at 11:39 AM

    This message was moderated.

    Add comment
    10|10000 characters needed characters exceeded