Skip to Content
0
Former Member
Nov 07, 2011 at 04:18 PM

Debugging CURTO_CREATE

259 Views

Hi,

We are trying to send recipe production versions from ECC to APO as SNP PDS.

The issue is to debug the queue to check parameters for enhancements. We've implemented the /SAPAPO/CURTO_SNP BADI and all the /SAPAPO/C4 and CFC2 settings are maintained.

In the first case, when trying to create integration model and activate it (CFM1/CFM2), the queue is available in SMQ2 on the APO end. Everything is fine in this case.

In the second case, when trying to send production version changes through CURTO_CREATE, we are unable to see the queue in SMQ2 on APO.

Tried all possible combinations of settings but while executing CURTO_CREATE, the queue is not visible for debug. On debugging CURTO_CREATE from ECC end, the FM /SAPAPO/CUSLNTRTO_CREATE_RTO is called remotely and the CIF queue is triggered. Tried setting debugging mode parameter in the FM but it gives an error (that's because we are using a system user in the RFC).

The strange thing is, I guess even through CFM1/CFM2, it should use RFC and the system user id, but the queue is available there for debug. It's only for the CURTO_CREATE (changes / delete) that the queue is not available.

Is there something I am missing while executing CURTO_CREATE? Changing the user id on the RFC should allow me to debug but want to know why the queue doesn't stay.