Skip to Content

An Error Occurred during CHART Generation in BI Launch Pad 4.0

Hi Guys,

I am creating a report on BI launch Pad, the query result shows fine in the "Table" format but when i "Turn Into" chart it gives me an error " An Error Occurred During chart generation, The chart cannot be displayed".

I created the same report in Rich Client and everything is working fine but on the portal the charts cannot be displayed.

Let me know if anyone has faced this error or has any solution for it.

Thanks in Advance,

Sheikh Hassan Ayub

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Nov 10, 2011 at 04:26 PM

    Hi, I'm getting the exact same problem...

    Either with Charts imported from BO XI 3.1 or when creating new ones...

    Always the same RED X top left and "an error occured during chart generation"

    "The chart cannot be displayed"

    Anybody else having the issue or fixed the problem ?

    Thanks,

    Julien

    Add comment
    10|10000 characters needed characters exceeded

    • try the following:

      1) We created a new Adaptive Processing server by stopping the existing one.

      2) Enabled and Started the new server.

      3) And now you were successfully able to Create, Open and Modify any web Intelligence reports in BI Launchpad.

      It worked for me.

      But the problem is that i had to re create the charts in BI launch pad, the old charts didnt work.

      If you have any other solution let me know.

      Sheikh Hassan Ayub

  • avatar image
    Former Member
    Jan 09, 2012 at 08:22 PM

    Hi Hassan -

    I also had the Same Issue, I followed and Created new Adaptive Job Server and all the Charts Work on the WebI reports.

    I reffered to other Forum and it directed me to make sure if I have made any Java Updates, that might also can be a cause of the Charts not showing up.

    However in my case fixing the Adaptive Job Server Fixed the issue.

    Thanks -

    Ahmed Syed

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello All,

      Am also facing the same problem.

      (Charts in Web Intelligence reports display Red X in BI 4.0)

      The solution for this is we need to configure the APS accordingly. In APS we need to add Visualization service explicitly and restart the APS resolves the issue.

      SAP note:1636890 has the steps for this issue.

      Regards

      Viswanadh Chaudary.B

  • avatar image
    Former Member
    Sep 12, 2014 at 06:14 AM

    Hi

    In case it helps to someone reading this post. I had the same issue, I had follow the best practice to split APS service in many separated services. After doing that, Chart were not displayed. The Best practices set the visualization server a separated server, once I included together with the Web Intelligent services the issue was solved.

    Thanks

    Teresa

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 19, 2015 at 02:45 PM

    Hello Experts,

    I had the similar and I had to restart my APS and APS(Visualization service) in my clustered environment and fixed my issue. How ever I saw many posts providing various solutions. We are on 4.1 sp2 patch2. I had this issue in one of our sandbox 4.1 sp5 and had to restart the APS and fixed it.

    Thank you for your time!

    Venkat

    Add comment
    10|10000 characters needed characters exceeded