Skip to Content
avatar image
Former Member

Error when installing NSP 7.02 => R3load.exe -testconnect rc = -1073740791

Hi,

I am trying to install NSP 7.02, but unfortunately I am stuck on an error.

The error comes when starting step u201CImport ABAPu201D.

The error is: u2018C:\usr\sap\NSP\SYS\exe\uc\NTI386\R3load.exe -testconnect' exits with error code -1073740791.

I already looked at the R3load.exe.log, but it is empty.

I am a developer and I donu2019t have a lot of knowledge about installing Netweaver, so I searched on the internet for a solution but I could not find it.

I did R3trans u2013d, and it returns the following:

This is r3trans version 6.19 (release 720 - 06.04.10 - 16:31:00 with UA1430.1 /

prepared for CSN 1287305).

unicode enabled version

2EETW169 no connect possible: "connect failed with DBLI_RC_LOAD_LIB_FAILED."

r3trans finished (0012).

I have tried several things: The 64 bits version, The 32 bits version, starting the MAXDB: NSP manually from services. When I open SAPMMC I don't see a db instance, but I donu2019t know if it should be already there.

Every time it gives the same error, what can I do?

Thanks in advance,

Regards, Robin

Edited by: Robin Vleeschhouwer on Oct 27, 2011 4:37 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 27, 2011 at 02:56 PM

    Hi,

    For R3trans -d to work, you have to login as <sid>adm. Only then the correct environment variables would be picked up for connecting to the database.

    Also, check if the MaxDB service is up and running correctly. Try to login to the DBM Gui and see if the database instance is created and online. Check out the link below for details regarding MaxDB DBM Gui:

    http://colliertech.org/index.php/MaxDB:Installation

    If the above fail, run the 'R3trans -d' command as <sid>adm and check the R3trans log in the directory from which the command was run. Post the contents of the same.

    Regards,

    Srikishan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 28, 2011 at 08:01 AM

    Hi Srikishan,

    Thanks for your fast answer.

    I installed MaxDB DMB GUI from the directory: \NWABAPTRIAL70206_64\MAXDBTOOLS

    and logged in with username u201Ccontrolu201D and used the password I gave in the installation.

    This was new for me and I learned something new about database management. Thank you for that.

    I solved the error but it was just a really stupid mistake from me.

    A friend told me once that when installing Netweaver I have to put the date in the future so that the license wonu2019t expire . So before I installed Netweaver I set the date to 2099.

    That was the problem, when I didnu2019t do that then there was no error message.

    Again thanks for helping.

    Regards, Robin

    Edited by: Robin Vleeschhouwer on Oct 28, 2011 10:01 AM

    Edited by: Robin on Oct 28, 2011 10:01 AM

    Add comment
    10|10000 characters needed characters exceeded