$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: false, vro: false, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content
0

HTTP Adapter Timeout Error

Dec 20, 2016 at 07:44 AM

41

avatar image
Former Member

Hi All,

I am receiving below error

<SAP:Category>XIAdapter</SAP:Category><SAP:Codearea="PLAINHTTP_ADAPTER">ATTRIBUTE_CLIENT</SAP:Code><SAP:P1>402</SAP:P1><SAP:P2>ICM_HTTP_TIMEOUT</SAP:P2><SAP:P3/><SAP:P4/><SAP:AdditionalText/><SAP:Stack>HTTP client code 402 reason ICM_HTTP_TIMEOUT </SAP:Stack>

Already referred :

https://blogs.sap.com/2006/06/08/xi-timeouts-timeouts-timeouts/

I have gone through above link but I want instead of globally increasing the HTTP_TIMEOUT, do we have any option for locally increasing timeout.


Thanks in advance for your reply.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Raghuraman S Dec 20, 2016 at 08:48 AM
0

Hello Nithin,

I dont think this is possible in plain HTTP Adpater.

In HTTP_AAE you can acheive using call sap adapter module.

Share
10 |10000 characters needed characters left characters exceeded