Skip to Content
avatar image
Former Member

Upgrade Error: sapcpe exited with 4

Hello,

we run currently an upgrade von SAP-Netweaver PI 7.1 SPS 6 to SAP Netweaver PI 7.1 EHP SPS 8.

At the beginning of downtime phase in step MAIN_SWITCH/SUBMOD_INSTNR_CHG/MOD_INSTNR_PRE we get the following error:

Severe error(s) occured in phase MAIN_SWITCH/SUBMOD_INSTNR_CHG/MOD_INSTNR_PRE!

Last error code set: Process /usr/sap/<SID>/SYS/exe/uc/sun_64/sapcpe exited with 4, see '/usr/sap/<SID>/SUM/abap/log/SAPCPE.OUT' for details

Next the SAPCPE.OUT

SAPup> Starting subprocess with PID 135 at 20111013160214
        ENV: DIR_LIBRARY=/usr/sap/<SID>/SYS/exe/uc/sun_64
        ENV: JAVA_HOME=/usr/java
        ENV: LD_LIBRARY_PATH=/usr/sap/<SID>/SYS/exe/uc/sun_64:/usr/sap/<SID>/SUM/jvm/jre/lib/sparcv9/server:/usr/sap/<SID>/SUM/jvm/jre/lib/sparcv9:/usr/sap/<SID>/SUM/jvm/jre/../lib/sparcv9:/oracle/client/10x_64/instantclient
        ENV: NLS_LANG=AMERICAN_AMERICA.UTF8
        ENV: ORACLE_BASE=/oracle
        ENV: ORACLE_HOME=/oracle/<SID>/102_64
        ENV: ORACLE_SID=<SID>
        ENV: PATH=/usr/sap/<SID>/SYS/exe/uc/sun_64:/oracle/<SID>/102_64/bin:/usr/java/bin:.:/home/<SID>adm:/usr/bin:/usr/ccs/bin:/usr/ucb
        ENV: SAPDATA_HOME=/oracle/<SID>
        ENV: SAPSYSTEMNAME=<SID>
        ENV: auth_shadow_upgrade=0
        ENV: dbms_type=ORA
        ENV: dbs_ora_schema=SAP<SID>
        ENV: dbs_ora_tnsname=<SID>

EXECUTING /usr/sap/<SID>/SYS/exe/uc/sun_64/sapcpe (sapcpe)  pf=/usr/sap/<SID>/SYS/profile/<SID>_DVEBMGS02_le06201
SAPup> Process with PID 135 terminated with status 4 at 20111013160215!

Please advice.

Regards

Christian Kaiser

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 13, 2011 at 02:41 PM

    What happens if you execute the command manually?

    /usr/sap/<SID>/SYS/exe/uc/sun_64/sapcpe pf=/usr/sap/<SID>/SYS/profile/<SID>_DVEBMGS02_le06201

    Markus

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi all,

      I have similar problem, but my error is:

      *** WARNING: ActualizeLocalFile: there is a problem to copy <src> because uid of <src> is 0

      , 2, No such file or directory, [sapxxcpe.c:2444]

      *** WARNING: ActualizeLocalFile: sapcpe skip copying <src>, because it is not able to set the right file mode to the target file

      , 2, No such file or directory, [sapxxcpe.c:2445]

      *** WARNING: ActualizeLocalFile: copy <src> to <dst> with root permissions

      , 2, No such file or directory, [sapxxcpe.c:2446]

      i dont know what the path is of src and dst and i can't even find the file sapxxcpe.c

      Thanks!

  • avatar image
    Former Member
    Aug 06, 2012 at 08:08 AM

    Hi,

    I know this was answered already but I thought I could add my contribution for the benefit of those whose problem relates to my context.

    I encountered this "sapcpe" problem during an EHP upgrade - NW EHP2, to be exact. The error message read exactly as your in the Software Update Manager.

    I solved the problem as follows:

    1. Look into sapcpe.SAV - the cpe log file.

    2. determine all the files that have WARNING.

    3. change the ownership of those files to <SID>adm:sapsys

    4. Some files (e.g. SAPOSCOL) need to run under root - these you have to copy manually to the target directory.

    5. Rerun/Repeat the phase in SUM.

    I hope this helps.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 21, 2012 at 11:04 AM

    Hi Elton,

    same problem for me with SUM in SOLUTION MANAGER 7.1 UPGRADE,

    there were 3 files with root ownership in different folders, solved the same way, changing ownership to <SID>adm. As a help for everybody, the sapcpe.SAV is located in <SUM directory>/abap/log

    Thanks and regards,

    Add comment
    10|10000 characters needed characters exceeded