Skip to Content
avatar image
Former Member

GRC10.0 MSMP Workflow - Access Request not getting presented to manager

Hi Gurus

We are in the process of GRC10 implementation and have set up GRC 2011 Test system with Support Pack level 05.

We are using Standard MSMP Workflow for Access Request processing and have come across following issue :

1. We have activated standard BC Set for MSMP workflow configuration.

2. After submitting the Access Request we find that the request is not getting presented to the Manager.

3. Further, when we initially started testing the Access Request, it did went to Manager for approval for first few requests.

4.To overcome, we tried activating the BC set again, however the request is still not flowing to Manager.

We have checked the workflow log the error "Agent not Found' is getting displayed.

Kindly Assist

Regards

Hemant

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Oct 09, 2011 at 02:12 PM

    Hi Hemant

    I would suggets you to check if agent is defined for Manager stage . As you already mentioned that few request were reaching manager I think some how Manager agent is changed .

    I would suggest to click on "Modify" for manager stage and check for agent .Dont try "Modify task setting to open manager stage .

    Thanks & Regards

    Asheesh

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Hemant,

      Have you also checked the IMG configuration standard settings to check that it is trying to route to Manager or Role Owner as standard? This is the first stage of routing.

      Once you have checked that, then make sure that you have the relevant owners assigned in the Access Controls Owners area and then assigned to the relevant master data elements.

      If you are using Manager, make sure that the access request also has the correct manager identified under User Details.

      Also, re confirm that your workflow does actually direct it to the Manager Agent and that this is appropriately documented in the path and stage config.

      Simon

  • avatar image
    Former Member
    Oct 13, 2011 at 10:16 AM

    Hi Hemanth,

    First of all go to MSMP and check whether agent :GRAC_MANAGER" is available or not in step 3 Maintain Agents, if yes then go to step 5 Maintain Paths in that select "GRAC_DEFAULT_PATH" path and in column Maintain Stages there should be atleast one stage with "GRAC_MANAGER" as Stage Config id and Agent Id should be "GRAC_MANAGER".

    Please check if these are missing then create it.

    Hopefully this will help to fix your issue!

    Thanks,

    Soman

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 26, 2011 at 09:56 PM

    Thanks for this thread. this was our issue too. we found S_A.SYSTEM was not sufficient and SAP_ALL fixed our issue.

    -Brian

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 02, 2012 at 02:54 PM

    Hello,

    we are in the process of GRC 10.0 implementation and set up a test system with Support Package level 06.

    When I try to activate the MSMP Workflow, I get the follwing: "MSMP Process activation resulted in errors."

    Transaction: GRFNMW_GEN_VERSION --> I get the following Issues:

    Database Table GRFNMWCNAGNT - record not found (key: SAP_GRAC_AR/MANAGER)

    Checking Definition of Agent 'MANAGER' (Process Type SAP_GRAC_AR) ...

    Agent ID 'MANAGER' is not for requested purpose 'Approval'; agent purpose = ''

    Can you help me?

    Thanks.

    Regards, Sabrina

    Add comment
    10|10000 characters needed characters exceeded