Skip to Content
avatar image
Former Member

"SEND EMAIL" task error

Hi all,

I got an issue in "SEND EMAIL" task in workflow. The task is using standard BOR "SELFITEM", method "SENDTASKDESCRIPTION" to send the email.

First of all, the "SEND EMAIL" task work fine in Development system. After move the workflow into Quality system, the "SEND EMAIL" never work.

I had checked and done following:

- Email can be send via SBWP, and received in my outlook.

- Manually run the BOR "SELFITEM", method "SENDTASKDESCRIPTION" in SWO1, and email send successfully.

- Checked ST22 and there is no short dump.

- Check SU53 for user WF-BATCH, and didn't see any auth issue.

- Retransport the workflow definition from Development system into Quality system (3 times), but still not working.

- The email address is provided directly to the ADDRESSSTRING from workflow container, no user id is needed in this task. I check the workflow log, the ADDRESSTRING holding correct email address.

The SAP system is ECC 6.0.

The error that I got from the workflow log is "Exception 1001, Message area SO, Number 23 : Document <XXX> could not be sent". I had no clue at the moment how this can be happen.

Do anyone here got experience in this issue before?

Besides that, do anyone know how to debug the "SENDTASKDESCRIPTION" when the workflow trigger it? This is a background task, and the method is a standard SAP program, I can't write a long run loop in the code to hold it for debug.

Regards,

Edison Wang

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 07, 2011 at 11:07 PM

    Hello,

    What happens when you provide a username instead? Be sure to add US to the front of it.

    What message type are you using for the email address? Double-check that it's a valid address, no spaces etc.

    regards

    Rick Bakker

    hanabi technology

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 20, 2015 at 06:43 PM

    Hsin

    I get the same error as soon as I select the SEND MAIL step. How do I resolve it. It creates some bindings on its own. How do I see the workflow log? WF_INITIATOR is being binded with ADDRESSSTRING. Please let me know, Thanks.

    Add comment
    10|10000 characters needed characters exceeded