Skip to Content
author's profile photo Former Member
Former Member

Crystal Reports Dynamic LOV error

I have created an LOV based on a dynamic field that has about 5000 records but not all are returned. I have created a new registry entry HKEY_LOCAL_MACHINE\Software\Business Objects\Suite 12.0\Crystal reports\DatabaseOptions\LOV and set a figure of 1000. Despite this, I sitll canu2019t see all the records.

Iu2019m running Crystal Server 2008 against an Oracle 10g database.

Anyone experienced this problem; kindly assist.

Thanks

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Sep 30, 2011 at 01:59 PM

    I think the default is 1000

    the reg setting you have just keeps the default

    if you want 5000+ you will need to set it to 5500 ( for example)

    NB there is a reason for a limit on these options why do you have 5000 in a LOV in the first place?

    also you will need to re-boot the server

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 30, 2011 at 02:42 PM

    Guys,

    I managed to solve the problem by making changes to HKEY_CURRENT_USER\SOFTWARE\Business Objects\Suite 11.0\Crystal Reports\DatabaseOptions\LOV

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 30, 2011 at 02:43 PM

    Managed to solve the problem.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 30, 2011 at 02:44 PM

    Hi,

    What string did you set the value 1000 to? It should be MaxRowsetRecords and the value certainly has to be greater than 5000 if you're expecting so many values.

    If you're viewing the report in the CR designer on the local machine, then the registry key needs to be created here as well. It needs to be under the HKEY_CURRENT_USER.

    Hope this helps!

    -Abhilash

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.