Skip to Content
0
Former Member
Sep 23, 2011 at 11:56 AM

Connection between SAP and Documentum

18 Views

Hi All,

We are retrieving some files from Documentum from an ABAP report in SAP using HTTP connection (using Web services). We were successful connections in DEV and QA.

Now in production, this server is load balacing on 3 servers. Their Prod Server is actually a content switch which redirects to one of the three servers. SAP is able to access all their three servers separately. However when I use the same code to access the Documentum content switch, it fails. We get a HTTP 404 - Not found error -

Here is the excerpt of code where this error is coming up-

CALL METHOD w_http_client->response->get_status

IMPORTING

code = lv_http_code

reason = lv_status_text.

This is pretty much my code I used which worked for Dev/ QA/ Prod individual servers (the content swtich doesnt work!)

CALL METHOD cl_http_client=>create_by_url

EXPORTING

url = w_string

proxy_host = hostname

proxy_service = port

IMPORTING

client = w_http_client

EXCEPTIONS

argument_not_found = 1

plugin_not_active = 2

internal_error = 3

OTHERS = 4.

CALL METHOD w_http_client->authenticate

EXPORTING

"PROXY_AUTHENTICATION = 'X'

username = lv_username

password = lv_password.

CALL METHOD w_http_client->send

EXCEPTIONS

http_communication_failure = 1

http_invalid_state = 2.

CALL METHOD w_http_client->receive

EXCEPTIONS

http_communication_failure = 1

http_invalid_state = 2

http_processing_failed = 3.

DATA: status_text TYPE string, http_code type i.

CALL METHOD w_http_client->response->get_status

IMPORTING

code = http_code

reason = status_text.

The Documentum Prod server (content switch) is supposed to be transparent and thus SAP should be able to connect. But this does not happen. Any ideas if any other config is required for SAP to connect to a content switch?

Pls advise.

Thanks in advance! Liz