Skip to Content
author's profile photo Former Member
Former Member

XML DataSource Not Showing When The Rept Is Printed,

My Background: I am new to the VS 2008, but not that new to Crystal, I had experience creating reports against MS SQL, and ODBC data.

Remedies tried:

I have updated VS 2008 to SP3, and updated Crystal with SP and FP to no avail.

Problem

Initially the report worked great, I created a new crystal report and used a XML file as the database through the wizard.

The report worked and looked as expected. I was tweaking it, moving and adding fields and toggling the preview and it was still fine. I then began trying to add a graphic and then when I previewed it some strange results started displaying like Orange lime, and color references, and nothing related to my XML data. The layout was the same but the data was strange.

I have tried using database expert, and location resetting but the problem persists. I checked the properties, and previewed the data and fields and the correct data shows up. I tried recreating the report from scratch and the problem persisted.

I then tried using a different XML file, made a simple and quick report and the same strange data showed on that report.

In exasperation I used my alternate version of Crystal Reports which I use against MS SQL, opened my original RPT file and `Viola, it shows perfectly with the right data. I turned around and re-opened it through the VS version and it still showed the erroneous data.

I hope my explanation was clear, any help will be appreciated.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Sep 21, 2011 at 09:23 PM

    What version of CR?

    Is the report working as expected in the CR Designer?

    If this is only happening at runtime

    Is this on your development computer or after you deploy the app?

    Provide your code as it pertains to setting the XML to the report

    Ludek

    Follow us on Twitter http://twitter.com/SAPCRNetSup

    Got Enhancement ideas? Try the [SAP Idea Place|https://ideas.sap.com/community/products_and_solutions/crystalreports]

    Add a comment
    10|10000 characters needed characters exceeded

    • Ok. I have to choose my testing of forum issue carefully as phones do take precedence. (see the blog [What are these 'support' forums good for anyhow?|/people/ludek.uher/blog/2011/04/07/what-are-these-support-forums-good-for-anyhow]).

      But I do find this issue interesting, just as frustrating as you 😊, and possibly not requiring that much time to test. A caution though; I will not be able to get to the test until next week, ok? - I'm leaving for my daughter;s hockey tournament as soon as I send this...

      I'll contact you over email and you can send the rpt and xml there.

      - Ludek

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.