Skip to Content
author's profile photo Former Member
Former Member

Would like to increase concurrent jobs in job server settings.

Hi All,

We are facing an issue like,scheduling jobs are stuck in pending status for long time as we have many reports that are recurring for same time.

we would like to increase the concurrence jobs number in CMC for every job server,

please advise.

thanks,

Brahma

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Dec 19, 2016 at 02:00 PM

    In my opinion, increasing the number of concurrent job would resolve the issue completely, but will give you some slag. Also try to give some interval between the schedule jobs to run. Running everything at the same time creates an over head over the BO services. Prioritize the jobs first.

    Add a comment
    10|10000 characters needed characters exceeded

    • Ideally you should increase the memory first, if this is prod box to at least to 48GB. Per server there should be 5 concurrent job by default (which should be sufficient if you properly plan the schedules to run). Given the current configuration you have, increasing to 10 jobs per server would definitely impact the performance of the environment. Also see which are long running reports and which reports are fetching too much of data. Give them the priority.

      Run the schedule during non-business hours.

  • Posted on Dec 19, 2016 at 01:38 PM

    It all depends on your server configuration, how many CPU and RAM in the server. Increasing the setting in Job server "Concurrent jobs" will not solve the issue. I think you may not have enough memory in the server or APS is not split properly.

    Can you share the details of your server configuration?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 19, 2016 at 01:42 PM

    Please find the server configuration below

    operating system: Windows

    Clustered,

    2 nodes.

    ram size:32GB

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.