Skip to Content
author's profile photo Former Member
Former Member

Cant see key fields in transfer structure

Hi All,

I created a datasource for a new ledger.. went to SBIW...>setting for Application specific Datasources(PI)...>financial accounting...>generate transfer structure for totals table ...> speciffied my table ...>generated extract structures for both totals records and line items...and went back to SBIW...>create infosource for ledger... i see the extract structure there namely ....3FI_SL_xx_TT(TOTALS RECORD) & 3FI_SL_xx_SI(LINE ITEMS).. Then i went back to BW.. replicated the datasources from the source system tab. I can see my datasource.

Here is the problem: when i'm trying to map the transfer structure to the communication structure .. i dont see any keyfields in my transfer structure(the one i generated in source system)...

Where am i going wrong? Is there any specific setting i need to take care? Pls guide me. Any step to step instructions would be very helpful.

Thanks in Advance.

Mav

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Feb 25, 2005 at 06:36 AM

    Hi Mav,

    in transfer rule maintenance, have you been on the datasoure/transferstructure tab to move the fields of the datasource into the transferstructure? After you have done this, you are able to map fields in the transfer rule tab. Another thing to check is, in R/3, datasource maintenance, check the settings in the column 'Hide field' and uncheck the checkbox for the required fields if it is checked.

    regards

    Siggi

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi John,

      thanks for the reply.. Actually i'm working on special ledger not in LO cockpit. How can i go and change the extract structure for a datasource in the R/3 for special ledger. I believe that all fields in a table are not included in a datasource. I can see only a few of them. Now i need to add some fields like "Value in Transaction Currency", "Value in local currency" etc. I can see these fields in the table, but not in the datasource.

      i APPENDED THE EXTRACT STRUCTURE ,, BUT I'M NOT ABLE TO ACTIVATE IT BUT ABLE TO SAVE IT.. IS THERE A WAY WHERE I CAN GO TO SAME APPEND STRUCTURE AND SEE WHAT THE PROBLEM IS .. BUT WHEN I;M TRYING TO APPEND AND PROVIDING WITH THE SAME EXTRACT STRUCTURE, IT SAYS SUCH A EXTRACT ALREADY EXISTS .. AND FORCING ME TO MAKE A NEW ONE EVERYTIME.

      THE ERROR MSG I'M GETTING WHILE TRYING TO ACTIVATE :

      Diagnosis

      Fields of customizing includes and append structures should lie in the customer namerange. You can then be sure that there will be no conflicts with SAP field names in future Release upgrades.

      The customer namerange for fields is YY and ZZ.

      Procedure

      If they are new fields or fields which are only used in structures, you are recommended to change the field names and the reports which access them.

      The field name for fields of database tables cannot be changed without the corresponding data being lost. It is only necessary to change the field name if the same name is used by SAP.

      Pls help. Thanks in advance.

      Mav.

  • author's profile photo Former Member
    Former Member
    Posted on Feb 25, 2005 at 07:08 AM

    Try also extractor checker with little data and see whether its pulling the key fields data. Otherwise we have to see if there is some other problem.

    Let me know if it helps.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.