Skip to Content
author's profile photo Former Member
Former Member

Post installation problems WAS 640 XI installation

Hi

The original installation of XI 3.0 pointed to the JDK 1_3_1

We have now patched the J2EE engine, and the relevant XI components up to Sp Stack 10 but when I perform the post installation activities I'm getting an error.

When I try to call the transaction SXMB_IFR - this calls the following URL http://<XI_host>:J2EE_Port>/rep/start/index.jsp - I get an error saying that JDK 1.4.2 is required. JDK 1.4.2 is installed on the host but as the installation originally pointed to JDK 1_3_1, this is what is looked for.

Which parameter needs to be set to point XI 3.0 to the updated 1_4_2 JDK ?

Assistance is greatly appreciated.

Thanks and Regards

Conor

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Feb 23, 2005 at 04:06 PM

    Also, when I installed XI 2.0 Basis SP stack 11 was required. It may be different for 3.0, but this also could cause a problem.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Harris,

      I would suggest to check the environment variables , JAVA_HOME and PATH.

      Apart from that please ensure that jstartup/vm/home is pointing to the correct jdk directory. This parameter is located in one instance profile. You can use RZ11 or report RSPARAM to check what it is currently set.

      Please do let me know if this solved your problem.

      -- Javed Ansari

  • author's profile photo Former Member
    Former Member
    Posted on Feb 23, 2005 at 04:05 PM

    You may want to make sure that you updated the original JDK and not just installed a new one. If you did install a new JDK you have to remember to change your environment variable to point to the new location. This may be a problem you're having.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 24, 2005 at 05:12 AM

    Regarding J2EE stack of XI, please check the JDK path in the

    <SID>/<Instance Name>/j2ee/cluster/instance.properties file.

    And if you find the old path in this file, change the path(not directly!) from ConfigTool.bat. Usually, JDK path of message Server, dispatcher, server and thier bootstrap should be changed.

    And change the following path also.

    <SID>/<Instance Name>/SDM/program/sdm_jdk.bat

    <SID>/<Instance Name>/SDM/program/config/sdm_jstartup.properties

    i hope this helps.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.