Skip to Content
avatar image
Former Member

HTTP Services using the Incorrect URL

We have a High Availability (multi app-server) NW 7.01 ABAP system that is set up to use HTTPS.

In front of this system in an F5 BIGIP server that is used for load balancing purposes.

As a user, I can enter an address from my GUI such as:

https://<FQDN>:443/sap/bc/ping?sap-client=100

Here the Fully Qualified Domain Name is an address that points to the F5 server, which in turn does a Round-Robin request to one of hte application servers on the SAP system.

But when I go to transaction SICF and run a test on the ping service, it gives the HTTP address:

http://<hostname><domain name>:<port>/sap/bc/ping?sap-client=100

Both tests work okay.

The problem I have is that when some HTTP services are called from our HTTPS enabled SAP Portal, they return data, but they use the above mentioned HTTP address, instead of the F5 HTTPS FQDN address. This causes the page to not display because the HTTPS SAP Portal screen will not display content embedded within it that is HTTP.

Please can you tell me how I can configure the HTTP services to always use HTTPS, with the correct FQDN (i.e. not the individual server's hostname)?

The relevant configuration I have is:

icm/server_port_0 PROT=HTTPS,PORT=443,TIMEOUT=60, PROCTIMEOUT=900

icm/host_name_full myhostname.mycompany.com

SAPSYSTEMNAME ABC

SAPGLOBALHOST myhostname

The configuration does not mention the FQDN that points to the F5 server. Does this need to be set somewhere, or should the HTTP services return data via the URL that was used in the initial request?

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Sep 15, 2011 at 03:17 AM

    Hi,

    In my opinion, the issue is due incorrect system alias settings for the ABAP system in the Portal.

    The protocol used for conencting to a backend system from the Portal is defined as HTTP of HTTPS in the system alias definition. In Portal -> System Administration -> Content -> System Landscape. Check the Web AS Protocol property to use 'HTTPS'.

    Next the Web AS hostname and Port should point to the load balancing host instead of the actualy ABAP host.

    More info: http://wiki.sdn.sap.com/wiki/display/EP/11Systems-+Creation

    Hope it helps.

    Regards,

    Srikishan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Srikishan,

      The Web AS hostname and Port are already correct, they point to the F5 server and are set to use HTTPS.

      Thanks.

  • avatar image
    Former Member
    Sep 15, 2011 at 06:47 PM

    you might want to use a reverse proxy.

    Add comment
    10|10000 characters needed characters exceeded