Skip to Content
author's profile photo Former Member
Former Member

Problem in ADOBE integration

Hello everybody,

I am developing one application for getting Sales order document's status. For this, I am using one BAPI which retrieves document status info. from SAP R/3. Now i want to show this status in adobe form. I have made one UIelemnt of Adobe and added one field for Sales document number and one field for document status and one submit button. Now when i supply document number and click on submit button, I am executing bapi to fetch status information from the R/3, which gives me back the status of the document.Now i want to show this status in textbox created in PDF form UIElement.

When i am submitting the document number, i can't get document status in status field. I have bind the field with context variable.

But i ccan't see the result.

What additional effort i have to take to accomplish this?

Regards,

Bhavik

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Feb 24, 2005 at 03:18 AM

    Hi,

    First of all check are you accessing the right BAPI,have you mapped import and return parameters to coustom/component controller inturn these mapped to view in view UI element bindings. have you chcked your Jco connection after deploying your application..

    I hope in your case check are you excuting right bapi and invoking that method at right location..

    your application seems to be simple...

    relook into above

    let me know

    RK

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 23, 2005 at 11:30 AM

    Hi,

    Did you maintain all the binding and links, and likewise also invalidate the Output node after calling the method in the executeBAPI.

    Please check these.

    Thanks,

    Pavan

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 24, 2005 at 05:29 AM

    Hey eveobody,

    It was my fault.

    I am mapping wrong fields from Model to controller. There are excactly two node for same information, one outside the output node and one inside the output node.

    I was mapping outside node whereas result is coming back in inside node.

    Thanks to all,

    Bhavik

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.