Skip to Content

SLD and RZ70 ->program SLD_NUC not registered error

Hi,

I have WebAS 6.40 loaded on my laptop and I am trying to set up the SLD to see our R/3 Enteprise system.

I connect to the R/3 system using a VPN and can ping the local ip address 10.0.0.5 from my laptop and can connect to the R/3 system without trouble. The R/3 system is called HENRY and the sysID is EN1

If I run smgw I see that the gateway host is HENRY and the service is sapgw00. I entered this in transaction RZ70 and in the Data Supplier Bridge in the SLD however I get RFC call failed: propgram SLD_NUC not regestered when I run RZ70 or test the RFC connection in SM59.

I tried replacing the word HENRY with 10.0.0.5 but still get the same error.

I have also added the following lines to my services file

sapgw00 3300/tcp

sapEN1 3600/tcp

Any help or ideas ?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Feb 23, 2005 at 04:20 AM

    Hi Richard

    Have you set "Update local SLD " to true in Data Supplier bridge Administration and also shouldnt it be

    <b>sapmsEN1 3600/tcp</b>

    Regards

    Pran

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 23, 2005 at 05:15 AM

    Hi Pran,

    The Update local SLD is set to True and the entry is sapmsEN1 - I made a typo.

    I can't help but feel the problem is with the Gateway Server. There is another post that says:

    "Data Supplier Bridge. In RFC Gateway give the complete domain name of the Gateway Server(you can lookup the hostname if you know the Ip address of the gateway. it should be something like IGATESAP05.xx.xx.com, otherwise it doesnt work). "

    I only have HENRY entered there as that is what I got from 'smgw'. How can I lookup the full hostname ?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 23, 2005 at 06:14 AM

    Mmmmm,

    I don't know what I did but it all of a sudden it worked !!

    All I did was change a setting in the SLD Server Settings. I changed the Persistence setting from Database to ABAP. However when I go back to that screen it is set to Database again ??

    My RFC Gateway setting is 10.0.0.5 (not HENRY) so that works as well.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.