Skip to Content
Former Member
Sep 13, 2011 at 08:50 AM

Extraction data 0CLM_INVOICE works partially, then discontinuous.


Dear BI Experts/Gurus,

I have searched endlessly on the forum and found lots of helpful information, however I can't seem to find a solution to the problem I am experiencing:

I am having trouble extracting the data (delta initialization) from the R/3 System to BW for the FSCM 0CLM_INVOICE datasource. Dependent on the company code selected for extraction, the data is extracted either without any problems or with errors. Half of the company codes I have tested can be loaded without any problems. I am loading data from the Q-system, which is a copy of the productive system (few months old); a system test/connection check has been done and does not display any errors. All other datasources/extraction jobs work, only this datasource (OCLM_INVOICE) is causing problems.

Here a short summary of the steps:

1) Running infopackage (limited to a small company code with records <1000) u2013 Data extraction u2018freezesu2019 after loading 810 records) - This problem occurs for half of the company codes with records ranging from <1000 to >1,000,000

2) RSA3 u2013 Extractor checker in ECC6 shows total records are 892.

3) SM50/SM66 (ECC6.0) (Global process overview) u2013 System still reading data (slowly but surely)

4) Process Monitor (BW) u2013 Yellow triangle u2013 not yet finished (After several hours, the last 82 records are not extracted)

5) The next day u2013 Process overdue error

Here is a more detailed overview of actions taken and error messages:

The problem that occurs is that the data is only loaded partially, for example 5xx,xxx records and then the job just gets stuck on processing (yellow triangle u2013 not yet finished).

When I check the process sm50 / sm66 it is still loading data, but if I let the job continue it will automatically stop after sometime due to u2013 process overdue error.

In ST22 (runtime error analysis) the error msg was u201CNo more storage space available for extending an internal tableu201C.

I tried to fix the problem through decreasing the load size in the infopackage from 20,000 to 10,000. This however still does not solve the problem, and instead displays the following message u2013 u201Cselected number does not agree with transferred numberu201D (Yellow triangle u2013 not yet finished).

The process monitor shows that data records retrieved are 810/0 but in the ECC (RS3 u2013 extraction checker shows no errors) the same datasource displays a total of 892 records. It seems as if the system cannot load the last 82 recordsu2026

I have additionally tried to (re)activate the datasource in the ECC through RSDS_DATASOURCE_ACTIVATE_ALL and (re)activate the transfer structure through RS_TRANSTRU_ACTIVATE_ALL. Iu2019ve replicated the metadata in BW for this datasource and reactivated it u2013 I did not get a single error message doing this.

I do get an error message when trying to compare the active datasource version with the content version = u201CVersion comparison with content version not possible (source system XXXXX)u201D --- Message no. RSDS169. I cannot find any information regarding this error message, so Iu2019m not sure if this has anything to do with the problem.

Does anyone know what the problem could be? I am having a hard time finding a solution!

Any help is much appreciated

Thanks in advance!


Edited by: Hugo00 on Sep 13, 2011 10:50 AM