Skip to Content
author's profile photo Former Member
Former Member

Outbound HTTP adapter and URL parameters

Hi all

I'm having some trouble with a XI scenario I'm supposed to implement.

I should get invoices from a vendors webserver using a url with parameters (ex. http://myvendor.com/getinvoice.jsp?invoiceid=12345) and send it as INVOICE IDoc to the R/3.

I thought that would be an easy one using the Plain HTTP-Adapter but I can't figure out how to build the URL. Is there a way to do that, or do I need to implement my own adapter??

Thanks in advance

Stefan

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Feb 22, 2005 at 02:04 PM

    You do not setup the inbound HTTP adapter. The vendor should post the message to your pipeline url. You only setup the HTTP adapter if the post is outbound from XI(eg receiver).

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 13, 2005 at 03:57 AM

    How about you build a custom internal webservice which communicates to your vendor website. You can call your webservice from XI and let the webservice handle the http invoice calls. This should be easier than building custom adapters. Just a thought..

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi experts ,

      I have this scenario from Legacy to XI to external app server.I have a test jsp to execute that functionality .Its a jsp which has 1 textarea named "test" and when I click on the submit buton I get a response back.This way I am able to test this independently.Now from XI when I am executing my scenario I am getting status code '1250' and message as ' http request(test) is null'.Now in the scenario in http adapter I just provide the target host : ip of server ,

      service number : port no ,

      path: the container or the request handler. But this scenario fails and gives me the above erroneous response.Now Basically I am not able to get how to send the value to the textarea "test"? please provide help as soon as possible.Do we have to put the name of the jsp in the "path" in http adapter and use prolog as test= or should it be &test= .I tried this but it doesnt work.So please provide help on this as soon as possible or please suggest a solution at akshata.m@gmail.com

      Thanx in advance,

      Akshata

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.