Skip to Content
0
Former Member
Sep 12, 2011 at 11:08 AM

Error deploying the application with Crystal Report

179 Views

Hello,

I'm using Visual Studio 2010 and I installed the required version of crystal report for it. I'm developing a windows Application with C# and Crystal Reports. The program runs correctly in the visual studio but when I tried to deploy it by adding the setup it gives me the following warnings:

- Unable to find dependency 'MICROSOFT.VISUALSTUDIO' (Signature='B03F5F7F11D50A3A' Version='1.0.5000.0') of assembly 'crdb_adoplus.dll'

+- The 'SAP Crystal Reports Runtime Engine for .NET Framework 4.0' item selected requires 'Microsoft.Net.Framework.2.0'. Select the missing prerequisite in the Prerequisites Dialog Box or create a bootstrapper package for the missing prerequisite. +

- No 'HomeSite' attribute has been provided for '.NET Framework 2.0 SP2', so the package will be published to the same location as the bootstrapper.

I tried to ignore the warnings and deploy it but when I try to open the crystal report and in the program it gives me an error message then an empty report.

I also tried in the Prerequisites to choose the option : Download prerequisites from the same location as my application. but when I do that I receive the following errors:

- The install location for prerequisites has not been set to 'component vendor's web site' and the file 'MDAC28\mdac_typ.exe' in item 'Microsoft Data Access Components 2.8' can not be located on disk. See Help for more information.

- General failure building bootstrapper.

- Unrecoverable building error.

of course In addition to the previous error.

I'm not using the click-once deployment.

Can you please help and advice me with that? I tried to search through the net for these warnings but with no luck of the solution.

Thank you,