Skip to Content

JCo server and MiniWAS 6.20

Hello!

I have a JCo server program which works fine with MiniSAP 4.6D as well as with "big" SAP WAS 6.20.

However, with MiniWAS 6.20 JCo server won't connect to the gateway. Otherwise, MiniWAS works fine (all GUI functions work normal).

I get error message "connection to partner broken". I checked a hudred times "services" and "hosts" files and everything looks fine (otherwise I doubt that GUI functions would work). Both Mini and JCo are running on the same PC (the same situation as with Mini 4.6D).

I searched SAP notes and found nothing. Below is a detailed error text.Thanks in advance for all inputs.

Kind regards,

Igor Barbaric

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

Connect to SAP gateway failed

Connect_PM TPNAME=JCO, GWHOST=IgorB, GWSERV=sapmsBSP

LOCATION CPIC (TCP/IP) on local host

ERROR connection to partner broken

TIME Mon Feb 21 15:51:41 2005

RELEASE 620

COMPONENT NI (network interface)

VERSION 36

RC -6

MODULE ninti.c

LINE 1074

DETAIL NiPRead (10.10.0.10/sapmsBSP)

SYSTEM CALL recv

COUNTER 1

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Feb 22, 2005 at 06:28 PM

    Hello Igor,

    have you tried to connect directly to the application server and not via the load balancing? I've described that also I a Weblog: https://www.sdn.sap.com/sdn/weblogs.sdn?blog=/pub/wlg/739. [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken]

    Regards

    Gregor

    Add comment
    10|10000 characters needed characters exceeded