Skip to Content
author's profile photo Former Member
Former Member

SAP Web AS 6.40 SR1 - Error on installation (JC00 startup)

Hi,

I am trying to install SAP Web AS 6.40 SR1 on a Solaris 5.8 64 Bits machine.

I got the necessary packages from SWDC (see topic ) and started the process. Everything went fine until I got the penultimate step, when SAPInst tries to restart the Java Engine and synchronize something... After 20 minutes waiting, I am finally getting an error like this (sapinst_dev.log):

TRACE<i> [syuxcaccmg.cpp:220]

bool CSyAccountMgtImpl::isExisting(ISyAccountMgt::eAccountType accountType, iastring sName)

Account gbsadm already exists.

TRACE<i> [syuxcaccmg.cpp:220]

bool CSyAccountMgtImpl::isExisting(ISyAccountMgt::eAccountType accountType, iastring sName)

Account 0 already exists.

TRACE [syuxcuser.cpp:378]

iastring CSyUserImpl::getHomeDirectory() const

account user="gbsadm" uid="5010" exists with parameter home="/sapmnt/"

TRACE [syuxctask.cpp:1242]

CSyTaskImpl::start(bool)

A child process has been started. Pid = 21656

TRACE<i> [syuxcaccmg.cpp:267]

bool CSyAccountMgtImpl::isExisting(ISyAccountMgt::eAccountType accountType, iastring sName)

Account sapsys already exists.

TRACE [syuxctask.cpp:1242]

CSyTaskImpl::start(bool)

A child process has been started. Pid = 21940

TRACE<i>

CJSlibModule::writeInfo_impl()

Output of /usr/sap/GBS/JC00/j2ee/os_libs/jcmon 'pf=/sapmnt/GBS/profile/GBS_JC00_blcsp01' is written to the logfile jcmon.log.

TRACE<i>

CJSlibModule::writeInfo_impl()

Execution of the command "/usr/sap/GBS/JC00/j2ee/os_libs/jcmon 'pf=/sapmnt/GBS/profile/GBS_JC00_blcsp01'" finished with return code 0. Output: snipped

TRACE<i>

CJSlibModule::writeInfo_impl()

J2EE Engine JC00 of SAP system GBS did not come up after 753 seconds: waiting for another 20 seconds.

I decided to restart the service by myself (as suggested by topic mut-03011-execution-of-the-command-cusrsapp64sysex) and see what happens, but got the same error.

Are you able to help me? I have already tried this installation 3 times!!!

Thanks in advance

Fernando Urzedo

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Feb 17, 2005 at 01:27 AM

    Hi, Fernando.

    i think your approach to start the J2EE server by yourself is good.

    > I decided to restart the service by myself

    What about checking that your J2EE processes are really started normally? The following processes should be checked.

    - 1 JControl process

    - 3 JLaunch processes(for dispatcher, server0, sdm)

    Frequently, server0 has problem when starting if your JVM parameters for server0 are not proper for your system.

    Good luck.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 17, 2005 at 07:38 AM

    Hi Fernando,

    to track the problem, you can have a look at the traces in the dev_jcontrol and dev_jcmon trace files located under the /usr/sap/GBS/JC00/work directory of your installation. If the dev_jcontrol file indicates an error in any of the bootstrap processes (bootstrap_<someID>), you can then further track the issue by having a look at the corresponding dev_boostrap_<ID> file in the same directory.

    It is likely that the server does not start due to memory problems. If this is the case, have a look at this thread dealing with such a problem: jcontrolexe-j2ee-server-stopped

    Hope that helps!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.