Skip to Content
author's profile photo Former Member
Former Member

Can't connect to MaxDB on Linux Host

Hi,

I've installed MaxDB on a Linux Server. This works fine, and local on linux I can connect to the database.

When I try to connect from my local DBMGui I become the message "-4 communication error".

After that i tryed to connect via dbmcli from my WindowsXP Workstation with this command:

DBMCli -n lir3max1 -d MAXDB1 -u DBM,DBM

But I only recive this Error Message:

Error! Connection failed to node lir3max1 for database MAXDB1: wrong DLL-Version, (check: SQLTCPx.DLL)

Can anybody help me to solve this problem.

Thanks

Johannes Geppert

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Feb 16, 2005 at 02:39 PM

    Hi Johannes,

    could you please do the following for me:

    1. Issue 'set' from a commandline window and copy the output in your answer here. It should display the current environment settings for the user with which you logged on.

    2. Search for 'sqltcp' in the registry (using Regedit). Please let me know what results you get.

    3. Tell me which MaxDB (client) version you have installed on your local Windows machine.

    Regards,

    Roland

    Message was edited by: Roland Mallmann

    Message was edited by: Roland Mallmann

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.