Skip to Content
avatar image
Former Member

"Color in system" not activated in Enjoy Theme

Hi experts,

I can set different color for different systems (DEV, QUA , PROD) but my user can't.

After logging in a system, in option, the "color in system" is blank for my user for Enjoy Theme : he has this message "to change/set settings on this page, you need to start the SAP GUI Options dialog in Enjoy Design" .

Does anyone know how to activate the "color in system" in the options?

Thanks in advance,

P.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Sep 01, 2011 at 11:58 AM

    Please read [Note 780864 - Color settings in the SAP GUI for Windows cannot be changed|https://websmp130.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=780864]

    It reads

    If you use the Enjoy Design "You cannot use the SAP GUI menu "Adjustment of local layout (ALTF12)" -> "Set color in the system" or "Adjustment of local layout (ALTF12)" -> "New design" -> "Color settings" to change the color settings of the SAP GUI. The list of possible color settings contains only the entry "normal"

    There is more information in the note but it sounds like your issue.

    Regards,

    Zecher

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 02, 2011 at 07:42 AM

    Hello Pete,

    The following provides additional information on the color theme

    settings:

    710719 SAP GUI family and New Visual Designs

    To set the default theme for all users of a system the parameter

    "sapgui/theme" in transaction RZ10 as detailed in note 610274.

    With this global theme set, this can be changed on the users side

    individually as per user desire.

    If you want to roll out themes as a script then you can use

    the following registry entries;

    Note that HKEY_CURRENT_USER will allow the end-user to make changes.

    If you wish to make the changes permanent then also use

    HKEY_LOCAL_MACHINE with the same registry entries and that

    should work.

    The following registry key:

    HKEY_CURRENT_USER\Software\SAP\General\Appearance\Systems\

    will list the systems that the user logs onto e.g. PRD1

    Under this registry setting there are 2 keys:

    ActiveColorSetting:

    Theme:

    which could be given the test value e.g

    For system PRD1

    HKEY_CURRENT_USER\Software\SAP\General\Appearance\Systems\PRD1

    ActiveColorSetting: Rose

    Theme: Enjoy

    And for another system TST1:

    HKEY_CURRENT_USER\Software\SAP\General\Appearance\Systems\TST1

    ActiveColorSetting: Peach

    Theme: Enjoy

    Please note that the above are just an example so I would recommend

    trying these out on several test machines on your side.

    As the above are manual registry changes please note the following:

    - If any undesired side effects occur then please remove the registry

    entries immediately.

    - If the changes are going to be used then please try on a test client.

    - Future patches may undo the registry changes and there is the

    possibility that the changes may not work correctly if future patches

    change the registry structure.

    - Please note that while this change appears to function correctly &

    without side-effects in our test system, undesirable effects from this

    change will not be supported by SAP until the registry entries are

    removed

    Hope this can assist you.

    BR,

    Jude

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 12, 2011 at 10:51 AM

    This happens when you are in SAP signature theme and try to change color setting of any theme. You can do color changes by setting current theme as enjoy theme, then you need to logoff SAP and start the SAP GUI Options dialog in Enjoy Theme.

    Regards,

    Shashi Bhooshan

    Add comment
    10|10000 characters needed characters exceeded

    • Not only you need to log off SAP but also completely exit the GUI / Logon utility right after switching to Enjoy Theme, and then restart it. Once you have restarted the GUI the color options will be available.