Skip to Content

SAP Netweaver 7.3 Message Server hostname issue (physical <> virtual)

Dears

Did anyone experience issues after a AS Java based SAP Netweaver 7.3 installation that the virtual hostname is not usable to access the AS Java? The installation was performed using SAPINST_USE_HOSTNAME and all configuration parameters are pointing to the virtual hostname.

The server has a seperate ip address assigned:

pyshical server - physical ip

virtual hostname - virtual ip

The SAP system is started using command

startsap -t ALL -v "<virtual hostname>"

When I look at the Message Server in /nwa under Configuration -> Infrastructure -> Message Server I can see that the physical ip address is assigned to the message server as well as the physical hostname.

The parameter that seems to be incorrect there is stated as server addr, server host and server host (fqn).

When the physical hostname is used access HTTP access works properly, the virtual hostname does not return anything.

We tried a bunch of things like changing the icm/server_post parameter to include the HOST or VHOSTIDX, SAPLOCALHOST, SAPLOCALHOSTFULL, icm/host_name_full, rdisp/mshost etc but it doesn't change anything.

I checked out the relevant SAP notes and /etc/hosts is maintained properly

niping -v -H <virtual host> works properly

In the dev_ms log I see that the startup process finds 3 hostnames (physical, local, virtual) and it seems he just picks the physical for some reason.

The configuration is done exactly as for SAP Netweaver 7.0 EHP1 or SAP Netweaver 7.1 where this all works fine so it seems to be related to the release SAP Netweaver 7.3 and perhaps also slightly different architecture although SAP Netweaver 7.1 is similar for the AS Java based part (both are SAPJVM based).

Any ideas?

Kind regards

Tom

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Aug 30, 2011 at 02:25 PM

    Sounds like a bug to me... as far as I understand the procedure for 7.3 installation on virtual hosts still dependant on SAPINST_USE_HOSTNAME

    Keep us up to date, I'll so some reading to see if I can find something that might help

    Regards

    Juan

    Add comment
    10|10000 characters needed characters exceeded

    • Hi David

      There was something wrong in the DNS server. I don't have details on it, I send out the issue at that moment in time to the network team and they found something eventually and fixed it by changing configuration in the DNS.

      Nothing on SAP application side made a difference or resolved the issue.

      Best regards

      Tom