Skip to Content
author's profile photo Former Member
Former Member

BO to SAP SSO error after applying SP02

Hi,

After applying SP02 on BO 4.0 , i get this error message when i try to use SSO between BO adn SAP BW using BICS OLAP connection. A colleague from different also complained the same:

Anyone experience this before or any thoughts?

Caused by: com.google.protobuf.UninitializedMessageException: Message missing required fields: bytesValue

at com.google.protobuf.AbstractMessage$Builder.newUninitializedMessageException(AbstractMessage.java:531)

at com.sap.sl.olap.sapbw.protobuf.generated.SapbwService$msgBytesValue$Builder.build(SapbwService.java:567)

at com.sap.sl.sdk.olap.sapbw.service.SapBwBrowsingServiceImpl.processDoIt(SapBwBrowsingServiceImpl.java:299)

at com.sap.sl.sdk.olap.sapbw.service.SapBwBrowsingServiceImpl.processInvocation(SapBwBrowsingServiceImpl.java:246)

at com.sap.sl.sdk.olap.sapbw.service.SapBwBrowsingServiceImpl.processOpenSession(SapBwBrowsingServiceImpl.java:229)

at com.sap.sl.sdk.olap.sapbw.service.SapBwBrowsingServiceImpl.openSession(SapBwBrowsingServiceImpl.java:59)

at com.sap.webi.ui.dialog.bex.ExpandRepositoryItemWorker.getBrowsingSession(ExpandRepositoryItemWorker.java:63)

at com.sap.webi.ui.dialog.bex.ExpandRepositoryItemWorker.doInBackground(ExpandRepositoryItemWorker.java:40)

at com.sap.webi.ui.dialog.bex.ExpandRepositoryItemWorker.doInBackground(ExpandRepositoryItemWorker.java:15)

at javax.swing.SwingWorker$1.call(SwingWorker.java:278)

at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)

at java.util.concurrent.FutureTask.run(FutureTask.java:138)

at javax.swing.SwingWorker.run(SwingWorker.java:317)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)

at java.lang.Thread.run(Thread.java:619)

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Aug 31, 2011 at 10:25 PM

    I got this additional error log WebRich client 4.0 SP02

    ===============

    |fbcb43c2-08c2-7584-8aab-5864797db098|2011 08 31 17:04:53:932|-0500|>>|E| |WebIRichClient| 3240|2908|| |0|10|0|0|-|-|-|-|-|-||||||||||||**ERROR:RequestProc:BOException : BOException caught:RESULT=80004005;WHAT=[[error.openSapBwBrowsingSessionFailed] 0] <com.sap.sl.olap.impl.ConnectionSpecificationImpl@fd3fba, networkLayerType: SAP_BW_BICS, providerType: SAP_BW7X, server: null, catalogName: null, cubeName: null, language: en)>,<[Internal] SSO token or User password is empty.> [kctRequestProc.cpp;461]

    kctRequestProc.cpp:768:void __thiscall cdztools::RequestProcBasic::generateResult(class OBFixSeq<unsigned char> *&,const char *,const char *,const char *,const unsigned char *,const unsigned char *,class std::basic_istream<char,struct std::char_traits<char> > *,int,bool &): TraceLog message 16

    |febbbc17-e993-4924-0bef-ffd7756899b2|2011 08 31 17:04:53:963|-0500|>>|E| |WebIRichClient| 3240|2908|| |0|10|0|0|-|-|-|-|-|-||||||||||||**ERROR:RequestProc:Error stream : <ERRORS>

    <ERROR COMPONENT="WIS" ERRORCODE="30270" ERRORTYPE="USER" MESSAGE="An internal error occured while calling &apos;doIt&apos; API. (Error: ERR_WIS_30270)" PREFIX="ERR">

    <DEBUGINFO BORESULT="5" FILENAME="kctRequestProc.cpp" LINEPOSITION="449" MODULENAME="IEPlugin_1"/>

    ===========

    Looks like the webi rich client is not getting SAP Assertion ticket from STS service. I can see the STS service active uner AdaptiveProcessingServer ... but no luck.

    Our BO 4.0 sp02 is installed 3 different servers (distributed).

    Any thoughts?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 02, 2011 at 06:44 PM

    Raised to SAP support. With the help from SAP Support, i got to know that i copied the certificate into BO instead of .p12 private key file. I am Dum 😊

    Thanks to everyone who thought of helping me here.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 12, 2011 at 08:31 PM

    Hi Srikar,

    We are getting same issue. Can you please describe the steps how to resolve this issue.

    Thank You,

    MS

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 12, 2011 at 09:01 PM

    That error mesage is a bit generic one. Any problem between BO and SAP using SSO will produce the same error message

    I am assuming that your problem is connecting from BO to SAP using SSO.

    Are you sure that it was working before application of SP02?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Solved! This error message com.google.protobuf.UninitializedMessageException is a bit generic one.

      My problem was access rights. I changed my user/password and forgot to change the user/password of the connection. So I changed it in the connection parameters in IDT (Information Design Tool) and created another connection just to garantee the test.

      Renitialized the IDT and it worked in both connections (new and old one).

      regards,

      Marco Modesto.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.