Skip to Content
author's profile photo Former Member
Former Member

BSP Application does not start

Hi All,

When I run my BSP in my CRM Server from SE80 it just gets hanged. Where as the same BSP works fine in another Server. Why is it so?

I have made the same BSP setting (SE80-> Utilities-> Settings) in both the Server.

I was told, that in addition to above mentioned, I would need to maintain some kind of Basis settings as well.

Could someone please tell me what this setting is?

Thanks in advance.

Regards,

Madhu

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Posted on Feb 14, 2005 at 05:15 AM

    check out the following weblogs.

    /people/brian.mckellar/blog/2004/06/11/bsp-trouble-shooting-getting-help

    /people/brian.mckellar/blog/2003/10/23/bsp-trouble-shooting-frequently-asked-short-questions

    Regards

    Raja

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 14, 2005 at 05:28 AM

    There is also the aspect of "compiling/generation" that you have to take in mind. On a newly updated/started system, the complete BSP runtime and all rendering classes must be compiled/generated. In addition, it might also be required to generate complete new loads for the specific BSP pages you are interested in. This can sometimes take a few minutes, and often you get timeouts in between. Just restart it a few times. To test for this, first keep starting BSP application SBSPEXT_HTML until it works (click through some controls). Then at least part of the system is "hot".

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Brian,

      As per your suggestion I tried to execute this application 'SBSPEXT_HTML' many times. But still i'm facing the same problem of 'Connection Time Outed'.

      Also in one of the Weblogs it was mentioned to check the result of FM 'ICF_IS_PLUGIN_SESSION'.

      In my system the result of this FM is -->

      PLUGIN_SESSION = N

      PLUGIN_PROTOCOL = 0

      What i need to do now?

      Regards,

      Madhu

  • Posted on Feb 14, 2005 at 11:25 AM

    Hi Madhuyukta,

    you have to set up (at least) the HTTP protocol correctly.

    Please have a look at

    http://help.sap.com/saphelp_erp2004/helpdata/en/56/2e453cabf4ef6fe10000000a114084/frameset.htm

    You can verify the settings by calling transaction smicm and then click on the services button. There has to be a HTTP protocol with a port number > 0 and a check mark at the column "Activated". If the system runs on a UNIX platform and you have chosen a port number < 1024, the external binding has to be activated.

    Regards,

    Rainer

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 14, 2005 at 11:52 AM

    Hi Rainer,

    I checked Services settings and found that HTTP protocol with a port number 9000 is Active. And also External binding is activated even though when the system runs on Windows NT.

    Should this External Binding be De-activated as its on Windows NT??

    Regrads,

    Madhu

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      External debugging needs to be activated if you intend to debug your applications regardless of system. So if you don't intend to debug for example "Production System" then you can deactivate the debugging.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.