Skip to Content
Former Member
Aug 25, 2011 at 11:00 AM

SPRUNCONSO copies Intercompany records in one Application, but not another.



I am experiencing a problem results with the SPRUNCONSO Stored Procedure.

We have two applications; a Statutory (Legal) App and a Management App (in the same AppSet). Both are of AppType=Consolidation. The shared dimensions are [Category, DataSrc, Time]. The dimensions specific to each Application are [Account, Analysis (U), Currency, Entity, Flow (S), Interco].

In the Statutory Application (which works fine), we consolidate the rollup base data (all of it, including all Flows (S) and Analysis (U)) from one DataSrc to another DataSrc. (The DataSrcu2019s are independent of each other). Looking at the dbo.CTBLAUDIT_CONSO table (which is where the SPRUNCONSO logs all its data to), all the records do what is expected of them. Specifically, I am looking at the Elimination Entities (Elim=Y in the member sheet) which is where the Intercompany Eliminations get posted to from Script Logic *WHEN CPE(u2026). (What this means is that the InterCo <> I_NONE for all the entries). In terms of Rules and Methods, Method=100 and the RuleType is Equity that writes the record.

In the Management Application, I copy the Automatic Adjustments and Automatic Adjustment Details from the Statutory Application. The Accounts are much the same. The same applies for the Entities (although the structure is naturally different). The only thing I do different is use US Elimination (SPRUNELIM) for Intercompany Elimination and post them to a separate DataSrc. It works fine.

However, when I run the consolidation for the Management Application, the only records that do not come across (from one DataSrc to the next) are the Intercompany Eliminations.

I have tried moving them into the same DataSrc as the rest of the data and re-running the Consolidation. No luck.

I have run the Consolidation limiting the Source Data Source (in Automatic Adjustment) to only where the Elimination records live. The error I then get is the following:


SPRunConso Version 7.0.115

ERROR CSD-150 Problem extracting Data : C_REPART

ERROR CSD-160 Problem extracting Data : C_CONSO

20110600 - 21 Rows Calculated

20110600 - 18 Rows Updated

(The errors do not appear if the Automatic Adjustment Source Data Source includes records that do get converted)

I can find no obvious difference in the member sheets between the non-shared dimension members. Both are YTD applications. I have spent ages looking for differences as to why it works in one Application, but not the other (just for a small collection of records). Iu2019m all out of ideas.

Any pointers where else I can look?