Skip to Content
author's profile photo Former Member
Former Member

Crystal Report 9 - Can't Display UTF-8 Data

Dear Sir,

I am using PHP with Crystal Report 9.2 and has problem displaying UTF-8 data from MSSQL field. It shows weird characters instead. I am very sure the data stored in database is in UTF-8 because when I ouput it into the web browser with encoding as UTF-8, it shows correctly. Currently is using ADODB recordset to pass data into CR. I tried using ODBC to connect directly to database and preview the data - same issue.

Now I wonder whether are there any settings need to be done in CR in order to display unicode correctly? From what I read, CR 9 and above should be able to support unicode.

Thanks

AL

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Aug 29, 2011 at 05:03 PM

    What CR SDK are you using?

    Ludek

    Follow us on Twitter http://twitter.com/SAPCRNetSup

    Got Enhancement ideas? Try the [SAP Idea Place|https://ideas.sap.com/community/products_and_solutions/crystalreports]

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.